aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-03-13 18:11:15 +0800
committerkris <kris@FreeBSD.org>2004-03-13 18:11:15 +0800
commit20cf99973577d77efe90364be92d14d48c2ce978 (patch)
treea86f2bcc1977d1428b33c3be762a35ee36c14583 /audio
parentcf671857cb4592248db7f0711ba150e40a2385a8 (diff)
downloadfreebsd-ports-gnome-20cf99973577d77efe90364be92d14d48c2ce978.tar.gz
freebsd-ports-gnome-20cf99973577d77efe90364be92d14d48c2ce978.tar.zst
freebsd-ports-gnome-20cf99973577d77efe90364be92d14d48c2ce978.zip
BROKEN on amd64 and ia64: Does not compile
Diffstat (limited to 'audio')
-rw-r--r--audio/spiralsynthmodular/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/audio/spiralsynthmodular/Makefile b/audio/spiralsynthmodular/Makefile
index 2dc2526184d7..510d03fab2ce 100644
--- a/audio/spiralsynthmodular/Makefile
+++ b/audio/spiralsynthmodular/Makefile
@@ -29,6 +29,12 @@ CONFIGURE_ENV= FLTK_CONFIG="${FLTK_CONFIG}" \
CFLAGS+= -O3 -ffast-math
.endif
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+BROKEN= "Does not compile on amd64 or ia64"
+.endif
+
pre-everything::
.if !defined(WITH_OPTIMIZED_CFLAGS)
@${ECHO_MSG} "You can enable additional compilation optimizations"
@@ -55,4 +61,4 @@ post-patch:
s,@FLTK_(C|CXX)FLAGS@,-I${X11BASE}/include,; \
s|-lpthread|${PTHREAD_LIBS}|g'
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>