aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-08-26 21:43:12 +0800
committerpi <pi@FreeBSD.org>2016-08-26 21:43:12 +0800
commit3852470f291287231280d4e7b76233e1b2e52911 (patch)
treeda751012cc96a8ee2fd69d6cba338e8147331cb2 /audio
parent5639ac9f031f4965056283d78aa14bf406795468 (diff)
downloadfreebsd-ports-gnome-3852470f291287231280d4e7b76233e1b2e52911.tar.gz
freebsd-ports-gnome-3852470f291287231280d4e7b76233e1b2e52911.tar.zst
freebsd-ports-gnome-3852470f291287231280d4e7b76233e1b2e52911.zip
audio/openal-soft: Add option to enable sndio support
- This adds support for building with the sndio audio output (audio/sndio). PR: 211664 Submitted by: Tobias Kortkamp <t@tobik.me> Approved by: mva (maintainer timeout)
Diffstat (limited to 'audio')
-rw-r--r--audio/openal-soft/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/audio/openal-soft/Makefile b/audio/openal-soft/Makefile
index da20712d8466..f2af33925603 100644
--- a/audio/openal-soft/Makefile
+++ b/audio/openal-soft/Makefile
@@ -24,7 +24,7 @@ CMAKE_ARGS+= -DALSOFT_REQUIRE_OSS:BOOL=ON \
-DALSOFT_UTILS:BOOL=ON \
-DALSOFT_EXAMPLES:BOOL=OFF
-OPTIONS_DEFINE= FLUIDSYNTH CONFIG PORTAUDIO PULSEAUDIO
+OPTIONS_DEFINE= FLUIDSYNTH CONFIG PORTAUDIO PULSEAUDIO SNDIO
OPTIONS_SUB= yes
CONFIG_DESC= Install configuration utility (needs Qt 4.x)
@@ -33,7 +33,7 @@ CONFIG_DESC= Install configuration utility (needs Qt 4.x)
#ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
CONFIG_CMAKE_ON= -DALSOFT_NO_CONFIG_UTIL:BOOL=OFF
CONFIG_CMAKE_OFF= -DALSOFT_NO_CONFIG_UTIL:BOOL=ON
-CONFIG_USE= QT4=corelib,gui,qmake_build,moc_build,rcc_build,uic_build
+CONFIG_USE= QT4=gui
FLUIDSYNTH_CMAKE_ON= -DALSOFT_REQUIRE_FLUIDSYNTH:BOOL=ON
FLUIDSYNTH_CMAKE_OFF= -DALSOFT_MIDI_FLUIDSYNTH:BOOL=OFF
FLUIDSYNTH_LIB_DEPENDS= libfluidsynth.so:audio/fluidsynth
@@ -43,6 +43,9 @@ PORTAUDIO_LIB_DEPENDS= libportaudio.so:audio/portaudio
PULSEAUDIO_CMAKE_ON= -DALSOFT_REQUIRE_PULSEAUDIO:BOOL=ON
PULSEAUDIO_CMAKE_OFF= -DALSOFT_BACKEND_PULSEAUDIO:BOOL=OFF
PULSEAUDIO_LIB_DEPENDS= libpulse-simple.so:audio/pulseaudio
+SNDIO_CMAKE_ON= -DALSOFT_REQUIRE_SNDIO:BOOL=ON
+SNDIO_CMAKE_OFF= -DALSOFT_BACKEND_SNDIO:BOOL=OFF
+SNDIO_LIB_DEPENDS= libsndio.so:audio/sndio
post-patch:
@${REINPLACE_CMD} 's|/etc/openal|${ETCDIR}|' \