aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authordecke <decke@FreeBSD.org>2013-11-18 20:03:42 +0800
committerdecke <decke@FreeBSD.org>2013-11-18 20:03:42 +0800
commit4a72f913d152fe5560b98412a801f191e959e106 (patch)
tree118f6392f45357f3946116d201847f9660d52752 /audio
parent3c44a88dea9ab8d4da05c4ae434c82896b798089 (diff)
downloadfreebsd-ports-gnome-4a72f913d152fe5560b98412a801f191e959e106.tar.gz
freebsd-ports-gnome-4a72f913d152fe5560b98412a801f191e959e106.tar.zst
freebsd-ports-gnome-4a72f913d152fe5560b98412a801f191e959e106.zip
- Update to 0.27
- Add staging support - Convert optional dependencies to new format - Add a few clang patches but switch to USE_GCC=any because there's quite some work left (contributors?)
Diffstat (limited to 'audio')
-rw-r--r--audio/mythplugin-mythmusic/Makefile28
-rw-r--r--audio/mythplugin-mythmusic/distinfo4
-rw-r--r--audio/mythplugin-mythmusic/files/patch-configure18
-rw-r--r--audio/mythplugin-mythmusic/pkg-plist3
4 files changed, 27 insertions, 26 deletions
diff --git a/audio/mythplugin-mythmusic/Makefile b/audio/mythplugin-mythmusic/Makefile
index 3a3d73500e65..373e8a25adf1 100644
--- a/audio/mythplugin-mythmusic/Makefile
+++ b/audio/mythplugin-mythmusic/Makefile
@@ -2,30 +2,32 @@
# $FreeBSD$
PORTNAME= mythmusic
-PORTVERSION= 0.26.1
+PORTVERSION= 0.27
CATEGORIES= audio
-MASTER_SITES= http://ftp.osuosl.org/pub/mythtv/ \
- http://ftp.osuosl.org/pub/mythtv/old_releases/ \
- http://ftp.oregonstate.edu/pub/mythtv/ \
- http://ftp.oregonstate.edu/pub/mythtv/old_releases/
PKGNAMEPREFIX= mythplugin-
-DISTNAME= mythplugins-${PORTVERSION}
+DISTNAME= mythtv-${PORTVERSION}
MAINTAINER= decke@FreeBSD.org
COMMENT= Music playing plugin for MythTV
-LIB_DEPENDS= cdio.13:${PORTSDIR}/sysutils/libcdio \
- FLAC:${PORTSDIR}/audio/flac \
- vorbis.4:${PORTSDIR}/audio/libvorbis \
- tag.1:${PORTSDIR}/audio/taglib \
- fftw3f:${PORTSDIR}/math/fftw3-float
+LIB_DEPENDS= libcdio.so:${PORTSDIR}/sysutils/libcdio \
+ libFLAC.so:${PORTSDIR}/audio/flac \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis \
+ libtag.so:${PORTSDIR}/audio/taglib \
+ libfftw3f.so:${PORTSDIR}/math/fftw3-float
BUILD_DEPENDS= mythfrontend:${PORTSDIR}/multimedia/mythtv
-USE_BZIP2= yes
-NO_STAGE= yes
+USE_GITHUB= yes
+GH_ACCOUNT= MythTV
+GH_PROJECT= mythtv
+GH_TAGNAME= v${PORTVERSION}
+
+WRKSRC= ${WRKDIR}/${GH_ACCOUNT}-${GH_PROJECT}-e9545c0/mythplugins
+
USE_QT4= linguist_build moc_build qmake_build rcc_build uic_build
HAS_CONFIGURE= yes
USE_LDCONFIG= ${PREFIX}/lib/mythtv/plugins
+DESTDIRNAME= INSTALL_ROOT
PLIST_SUB+= MYTHSHARE="share/mythtv"
diff --git a/audio/mythplugin-mythmusic/distinfo b/audio/mythplugin-mythmusic/distinfo
index 9eb79c986f0e..66c307cfbe08 100644
--- a/audio/mythplugin-mythmusic/distinfo
+++ b/audio/mythplugin-mythmusic/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mythplugins-0.26.1.tar.bz2) = 6db50887dac35471b408cc8365c84f2a8522be7045b8e81de13ff16d840fc928
-SIZE (mythplugins-0.26.1.tar.bz2) = 36718864
+SHA256 (mythtv-0.27.tar.gz) = e8d77c48f487bd057b2f887c27416d502b79c78c4e1cfb05d87ec70d690f8d0d
+SIZE (mythtv-0.27.tar.gz) = 85915149
diff --git a/audio/mythplugin-mythmusic/files/patch-configure b/audio/mythplugin-mythmusic/files/patch-configure
index 97364c01fe8d..b2ea71eb1643 100644
--- a/audio/mythplugin-mythmusic/files/patch-configure
+++ b/audio/mythplugin-mythmusic/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig 2012-04-10 07:29:22.000000000 +0200
-+++ configure 2012-04-13 22:04:24.501203271 +0200
+--- configure.orig 2013-09-18 20:06:08.000000000 +0000
++++ configure 2013-10-16 15:21:39.000000000 +0000
@@ -227,6 +227,10 @@
append ECXXFLAGS "$@"
}
@@ -11,18 +11,18 @@
check_cxx(){
log check_cxx "$@"
cat > $TMPCXX
-@@ -555,6 +559,10 @@
- CXXPPFLAGS=${CXXPPFLAGS#CXXPPFLAGS=}
- OPENGLV=$(cat mythconfig.mak | grep -e "^CONFIG_OPENGL_VIDEO=yes")
+@@ -561,6 +565,10 @@
+ EXTRALIBS=$(cat mythconfig.mak | grep -e "^EXTRALIBS=")
+ EXTRALIBS=${EXTRALIBS#EXTRALIBS=}
+add_cppflags "-I${prefix}/include"
+add_cxxflags "-I${prefix}/include"
+add_ldflags "-L${prefix}/lib"
+
- if ! is_qmake4 $qmake; then
- is_qmake4 qmake-qt4 && qmake=qmake-qt4 || die "qmake for Qt4.6 or newer not found.\nPlease specify the correct qmake with --qmake="
- fi
-@@ -646,6 +654,7 @@
+ if ! is_qmake5 $qmake ; then
+ if ! is_qmake4 $qmake; then
+ is_qmake4 qmake-qt4 && qmake=qmake-qt4 || die "qmake for Qt4.8 or newer not found.\nPlease specify the correct qmake with --qmake="
+@@ -653,6 +661,7 @@
echo "MythMusic requires FLAC."
fi
diff --git a/audio/mythplugin-mythmusic/pkg-plist b/audio/mythplugin-mythmusic/pkg-plist
index b78d2d177c6d..1b1631e20ab7 100644
--- a/audio/mythplugin-mythmusic/pkg-plist
+++ b/audio/mythplugin-mythmusic/pkg-plist
@@ -1,4 +1,3 @@
-@comment $FreeBSD$
lib/mythtv/plugins/libmythmusic.so
%%MYTHSHARE%%/i18n/mythmusic_ca.qm
%%MYTHSHARE%%/i18n/mythmusic_cs.qm
@@ -48,6 +47,7 @@ lib/mythtv/plugins/libmythmusic.so
%%MYTHSHARE%%/themes/default/mm_blackhole_border.png
%%MYTHSHARE%%/themes/default/mm_browser_back_reg.png
%%MYTHSHARE%%/themes/default/mm_browser_back_sel.png
+%%MYTHSHARE%%/themes/default/mm_cd.png
%%MYTHSHARE%%/themes/default/mm_compartists.png
%%MYTHSHARE%%/themes/default/mm_compilations.png
%%MYTHSHARE%%/themes/default/mm_descending.png
@@ -121,6 +121,5 @@ lib/mythtv/plugins/libmythmusic.so
%%MYTHSHARE%%/themes/default/stop_button_pushed.png
%%MYTHSHARE%%/themes/default/stream-ui.xml
%%MYTHSHARE%%/themes/default/track_info_background.png
-@dirrmtry lib/pkgconfig
@dirrmtry lib/mythtv/plugins
@dirrm %%MYTHSHARE%%/mythmusic