aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-03-25 13:44:08 +0800
committerpat <pat@FreeBSD.org>2002-03-25 13:44:08 +0800
commit4aa24c6bf4c0b2452d936f4b41180c5a6a2bb5a6 (patch)
treef1ef14327606b7c76e6815904c2c42cf027f5f4c /audio
parentfc9a922f5a3486721885175a4608ad37bb403ed7 (diff)
downloadfreebsd-ports-gnome-4aa24c6bf4c0b2452d936f4b41180c5a6a2bb5a6.tar.gz
freebsd-ports-gnome-4aa24c6bf4c0b2452d936f4b41180c5a6a2bb5a6.tar.zst
freebsd-ports-gnome-4aa24c6bf4c0b2452d936f4b41180c5a6a2bb5a6.zip
Update to 1.5.0
Approved by: petef(maintainer)
Diffstat (limited to 'audio')
-rw-r--r--audio/napster/Makefile2
-rw-r--r--audio/napster/distinfo2
-rw-r--r--audio/napster/files/patch-cmds.c12
-rw-r--r--audio/napster/files/patch-nap.c22
4 files changed, 36 insertions, 2 deletions
diff --git a/audio/napster/Makefile b/audio/napster/Makefile
index 501014c6548b..3d9f1b55087c 100644
--- a/audio/napster/Makefile
+++ b/audio/napster/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nap
-PORTVERSION= 1.4.8
+PORTVERSION= 1.5.0
CATEGORIES= audio net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= nap
diff --git a/audio/napster/distinfo b/audio/napster/distinfo
index d269a4d05623..9e3dce3ef7f8 100644
--- a/audio/napster/distinfo
+++ b/audio/napster/distinfo
@@ -1 +1 @@
-MD5 (nap-1.4.8.tar.gz) = a892969328f380fd0c87a886d6f0dcdd
+MD5 (nap-1.5.0.tar.gz) = 37f212b818e4d0a1674ddd63f638e1b3
diff --git a/audio/napster/files/patch-cmds.c b/audio/napster/files/patch-cmds.c
new file mode 100644
index 000000000000..940c1c002e56
--- /dev/null
+++ b/audio/napster/files/patch-cmds.c
@@ -0,0 +1,12 @@
+--- cmds.c.orig Sat Mar 9 17:29:08 2002
++++ cmds.c Sat Mar 9 17:29:41 2002
+@@ -19,8 +19,8 @@
+ #include <dlfcn.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
+-#include <arpa/inet.h>
+ #include <netinet/in.h>
++#include <arpa/inet.h>
+ #include <sys/time.h>
+ #include <unistd.h>
+ #include <signal.h>
diff --git a/audio/napster/files/patch-nap.c b/audio/napster/files/patch-nap.c
new file mode 100644
index 000000000000..77af9210480c
--- /dev/null
+++ b/audio/napster/files/patch-nap.c
@@ -0,0 +1,22 @@
+--- nap.c.orig Fri Mar 1 11:17:37 2002
++++ nap.c Sat Mar 9 17:24:26 2002
+@@ -1987,7 +1987,7 @@
+ char *buf;
+ char *p;
+ int i, r;
+- int timeout;
++ int timeout, on = 1;
+
+ timeout = nvar_default("connecttimeout", CONNECTTIMEOUT);
+
+@@ -2010,6 +2010,10 @@
+ wp(wchan, "Error creating socket: %s\n", strerror(errno));
+ drw(wchan);
+ return(-1);
++ }
++
++ if (setsockopt(s, SOL_SOCKET, SO_REUSEADDR, &on, sizeof(on)) == -1) {
++ perror("setsockopt(SO_REUSEADDR)");
+ }
+
+ if (connect_t(s, (struct sockaddr *)&dst, sizeof(dst), timeout) == -1) {