aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorgreen <green@FreeBSD.org>2004-09-01 09:28:52 +0800
committergreen <green@FreeBSD.org>2004-09-01 09:28:52 +0800
commit525507865ff007f9d17590861056406af7f4a686 (patch)
tree6e2125ac3609e42a12c0813af0983b4283b4ecfb /audio
parentc1cec095666745b87149595056975a3e7edeeda1 (diff)
downloadfreebsd-ports-gnome-525507865ff007f9d17590861056406af7f4a686.tar.gz
freebsd-ports-gnome-525507865ff007f9d17590861056406af7f4a686.tar.zst
freebsd-ports-gnome-525507865ff007f9d17590861056406af7f4a686.zip
Add patch files which for some reason "pcvs add" did not, the first time.
Diffstat (limited to 'audio')
-rw-r--r--audio/xmms-imms/files/patch-Makefile8
-rw-r--r--audio/xmms-imms/files/patch-playlist.h15
-rw-r--r--audio/xmms-imms/files/patch-sqlite++.h16
3 files changed, 39 insertions, 0 deletions
diff --git a/audio/xmms-imms/files/patch-Makefile b/audio/xmms-imms/files/patch-Makefile
new file mode 100644
index 000000000000..8dbbfbfaabde
--- /dev/null
+++ b/audio/xmms-imms/files/patch-Makefile
@@ -0,0 +1,8 @@
+--- Makefile.orig Wed Aug 18 01:56:28 2004
++++ Makefile Tue Aug 31 15:38:44 2004
+@@ -32,4 +32,4 @@
+ vars.mk:;
+
+ %:
+- @make -C build --no-print-directory $@
++ @${MAKE} -C build --no-print-directory $@
diff --git a/audio/xmms-imms/files/patch-playlist.h b/audio/xmms-imms/files/patch-playlist.h
new file mode 100644
index 000000000000..f70c002a6dcd
--- /dev/null
+++ b/audio/xmms-imms/files/patch-playlist.h
@@ -0,0 +1,15 @@
+--- playlist.h.orig Wed Aug 18 01:56:28 2004
++++ playlist.h Tue Aug 31 16:03:12 2004
+@@ -3,10 +3,11 @@
+
+ #include "immsconf.h"
+ #include "basicdb.h"
++#include "utils.h"
+
+ #include <vector>
+
+-class PlaylistDb : virtual public BasicDb
++class PlaylistDb : protected ImmsRandom, virtual public BasicDb
+ {
+ public:
+ void playlist_insert_item(int pos, const string &path);
diff --git a/audio/xmms-imms/files/patch-sqlite++.h b/audio/xmms-imms/files/patch-sqlite++.h
new file mode 100644
index 000000000000..a3f1ae322260
--- /dev/null
+++ b/audio/xmms-imms/files/patch-sqlite++.h
@@ -0,0 +1,16 @@
+--- sqlite++.h.orig Wed Aug 18 01:56:28 2004
++++ sqlite++.h Tue Aug 31 15:40:23 2004
+@@ -98,13 +98,11 @@
+ SQLQuery &operator<<(int i);
+ SQLQuery &operator<<(double i);
+ SQLQuery &operator<<(float i) { return *this << double(i); }
+- SQLQuery &operator<<(time_t i) { return *this << (int)i; }
+ SQLQuery &operator<<(const string &s);
+
+ SQLQuery &operator>>(int &i);
+ SQLQuery &operator>>(double &i);
+ SQLQuery &operator>>(float &i);
+- SQLQuery &operator>>(time_t &i) { return *this >> ((int&)i); }
+ SQLQuery &operator>>(string &s);
+
+ private: