aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2001-12-23 11:57:35 +0800
committerpetef <petef@FreeBSD.org>2001-12-23 11:57:35 +0800
commit5738a1daba8d7fbaafba9bd9f7d0a305b3365ae0 (patch)
tree8f049e46a8c1f985bef40c79a2bfabb62fbf3cde /audio
parent81fb289d33dd836bbccd92efd6dba4ec13566e74 (diff)
downloadfreebsd-ports-gnome-5738a1daba8d7fbaafba9bd9f7d0a305b3365ae0.tar.gz
freebsd-ports-gnome-5738a1daba8d7fbaafba9bd9f7d0a305b3365ae0.tar.zst
freebsd-ports-gnome-5738a1daba8d7fbaafba9bd9f7d0a305b3365ae0.zip
- fix a typo when commenting out VORBIS in pkg-plist substitutions
- fix the ownership of files in ${PREFIX}/share/freeamp PR: 33101, 33096 Submitted by: Alan Eldridge <alane@geeksrus.net> Noticed by: John Merryweather Cooper <john_m_cooper@yahoo.com>
Diffstat (limited to 'audio')
-rw-r--r--audio/freeamp/Makefile3
-rw-r--r--audio/zinf/Makefile3
2 files changed, 4 insertions, 2 deletions
diff --git a/audio/freeamp/Makefile b/audio/freeamp/Makefile
index 95fc9570ef56..4fabe5534daf 100644
--- a/audio/freeamp/Makefile
+++ b/audio/freeamp/Makefile
@@ -55,7 +55,7 @@ LIB_DEPENDS+= vorbis.0:${PORTSDIR}/audio/libvorbis
PLIST_SUB+= VORBIS=""
.else
CONFIGURE_ARGS+= --disable-vorbis
-PLIST_SUB+= VORBIS="@comment"
+PLIST_SUB+= VORBIS="@comment "
.endif
pre-everything::
@@ -73,5 +73,6 @@ post-install:
@${MKDIR} ${PREFIX}/etc/sdr/plugins
${INSTALL_DATA} ${FILESDIR}/sdr2.plugin.S100.audio.rtp.mpa.freeamp \
${PREFIX}/etc/sdr/plugins
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/freeamp
.include <bsd.port.post.mk>
diff --git a/audio/zinf/Makefile b/audio/zinf/Makefile
index 95fc9570ef56..4fabe5534daf 100644
--- a/audio/zinf/Makefile
+++ b/audio/zinf/Makefile
@@ -55,7 +55,7 @@ LIB_DEPENDS+= vorbis.0:${PORTSDIR}/audio/libvorbis
PLIST_SUB+= VORBIS=""
.else
CONFIGURE_ARGS+= --disable-vorbis
-PLIST_SUB+= VORBIS="@comment"
+PLIST_SUB+= VORBIS="@comment "
.endif
pre-everything::
@@ -73,5 +73,6 @@ post-install:
@${MKDIR} ${PREFIX}/etc/sdr/plugins
${INSTALL_DATA} ${FILESDIR}/sdr2.plugin.S100.audio.rtp.mpa.freeamp \
${PREFIX}/etc/sdr/plugins
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/freeamp
.include <bsd.port.post.mk>