aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-01-22 20:50:08 +0800
committertcberner <tcberner@FreeBSD.org>2017-01-22 20:50:08 +0800
commit76f2c6eb11ee5117763824656f3b1af20bb0d00a (patch)
tree827322b9ddfac8cde006015de22267be471f0537 /audio
parentbc40b2d3b031e7a3a555e8176df5f811a3fed26b (diff)
downloadfreebsd-ports-gnome-76f2c6eb11ee5117763824656f3b1af20bb0d00a.tar.gz
freebsd-ports-gnome-76f2c6eb11ee5117763824656f3b1af20bb0d00a.tar.zst
freebsd-ports-gnome-76f2c6eb11ee5117763824656f3b1af20bb0d00a.zip
Update math/gmm++ to 5.1
Due to it requiring c++11 features now, the consumers audio/csound and audio/csound6 we're version bumped, and set USE_CXXSTD. * http://download.gna.org/getfem/html/homepage/whatsnew/5.0.html * http://download.gna.org/getfem/html/homepage/whatsnew/5.1.html Reviewed by: rakuco Approved by: rakuco (mentor) Differential Revision: https://reviews.freebsd.org/D7730
Diffstat (limited to 'audio')
-rw-r--r--audio/csound/Makefile4
-rw-r--r--audio/csound6/Makefile4
2 files changed, 6 insertions, 2 deletions
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index a7e6f6af6356..883b8fc95629 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -3,7 +3,7 @@
PORTNAME= csound
PORTVERSION= 5.19.01
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= audio lang
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}${PORTVERSION:R} \
SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}${PORTVERSION:R}/manual:manual
@@ -28,6 +28,8 @@ CONFLICTS_INSTALL= outguess-* csound6
WRKSRC= ${WRKDIR}/${PORTNAME:S/c/C/}${PORTVERSION}
USES= bison cpe gettext scons compiler:openmp python
+# math/gmm++ requires c++11
+USE_CXXSTD= c++11
CPE_VENDOR= csounds
MAKE_ARGS= instdir="${STAGEDIR}" prefix="${PREFIX}" \
CC="${CC}" CXX="${CXX}" \
diff --git a/audio/csound6/Makefile b/audio/csound6/Makefile
index 155739cd16c1..ef30a7f4ed12 100644
--- a/audio/csound6/Makefile
+++ b/audio/csound6/Makefile
@@ -3,7 +3,7 @@
PORTNAME= csound
PORTVERSION= 6.06
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio lang
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}6/${PORTNAME:S/c/C/}${PORTVERSION}
PKGNAMESUFFIX= 6
@@ -24,6 +24,8 @@ LIB_DEPENDS= libsamplerate.so:audio/libsamplerate \
libsndfile.so:audio/libsndfile
USES= alias bison cmake:outsource localbase python:2
+# math/gmm++ requires c++11
+USE_CXXSTD= c++11
CMAKE_ARGS= -DBUILD_CSOUNDVST:BOOL=OFF \
-DBUILD_JAVA_INTERFACE:BOOL=OFF \
-DBUILD_P5GLOVE_OPCODES:BOOL=OFF \