aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-01-13 20:45:07 +0800
committertobik <tobik@FreeBSD.org>2018-01-13 20:45:07 +0800
commit7a031073ee27989610fdbd5c555c78141acf1001 (patch)
treecdb39d2c4071ab72aa057a5f7c0ac85352611e11 /audio
parent3c3c6f6bfbd014f02f9be3e22f4ef4144c4f62f1 (diff)
downloadfreebsd-ports-gnome-7a031073ee27989610fdbd5c555c78141acf1001.tar.gz
freebsd-ports-gnome-7a031073ee27989610fdbd5c555c78141acf1001.tar.zst
freebsd-ports-gnome-7a031073ee27989610fdbd5c555c78141acf1001.zip
audio/sndio: Update to 1.4.0
There are no code changes in libsndio, but the major/minor of libsndio was bumped to 7.0 in this release to match libsndio on OpenBSD regardless. On OpenBSD some private symbols were hidden via a version script. This is not yet part of the portable release. Avoid causing unnecessary churn and keep using 6.1 for the time being.
Diffstat (limited to 'audio')
-rw-r--r--audio/sndio/Makefile4
-rw-r--r--audio/sndio/distinfo6
-rw-r--r--audio/sndio/files/patch-configure13
-rw-r--r--audio/sndio/files/patch-libsndio_Makefile.in20
4 files changed, 29 insertions, 14 deletions
diff --git a/audio/sndio/Makefile b/audio/sndio/Makefile
index 1ca4304d8d8c..bd2011ff2306 100644
--- a/audio/sndio/Makefile
+++ b/audio/sndio/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= sndio
-PORTVERSION= 1.3.0
+PORTVERSION= 1.4.0
CATEGORIES= audio
MASTER_SITES= http://www.sndio.org/
@@ -12,7 +12,7 @@ COMMENT= Small audio and MIDI framework from the OpenBSD project
LICENSE= ISCL
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${PREFIX}/man --enable-oss
+CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${PREFIX}/man
USE_LDCONFIG= yes
USE_RC_SUBR= sndiod
diff --git a/audio/sndio/distinfo b/audio/sndio/distinfo
index 9b5be2a6a558..abd3f9e14b93 100644
--- a/audio/sndio/distinfo
+++ b/audio/sndio/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1510685728
-SHA256 (sndio-1.3.0.tar.gz) = bcc33213f02adc71bd0c3543f3b243847e7d27c5243b0b558182bc1b3056e4b1
-SIZE (sndio-1.3.0.tar.gz) = 125955
+TIMESTAMP = 1515842737
+SHA256 (sndio-1.4.0.tar.gz) = 68713db624797dbff69c0f4ce1b24054fb0803da340508edbc5e08d6778f9781
+SIZE (sndio-1.4.0.tar.gz) = 126007
diff --git a/audio/sndio/files/patch-configure b/audio/sndio/files/patch-configure
new file mode 100644
index 000000000000..7531c57cd8a6
--- /dev/null
+++ b/audio/sndio/files/patch-configure
@@ -0,0 +1,13 @@
+--- configure.orig 2018-01-11 20:57:37 UTC
++++ configure
+@@ -80,8 +80,10 @@ case `uname` in
+ -DHAVE_SOCK_CLOEXEC -DHAVE_CLOCK_GETTIME'
+ ;;
+ DragonFly|FreeBSD)
++ oss=yes
+ umidi=yes
+ user=_sndio
++ so_ldflags="-Wl,-soname=libsndio.so.\${MAJ}.\${MIN}"
+ so_link="libsndio.so"
+ defs='-DHAVE_ARC4RANDOM -DHAVE_ISSETUGID \\\
+ -DHAVE_STRLCAT -DHAVE_STRLCPY -DHAVE_STRTONUM \\\
diff --git a/audio/sndio/files/patch-libsndio_Makefile.in b/audio/sndio/files/patch-libsndio_Makefile.in
index 5ee65d3cb5f6..f242543352ba 100644
--- a/audio/sndio/files/patch-libsndio_Makefile.in
+++ b/audio/sndio/files/patch-libsndio_Makefile.in
@@ -1,11 +1,13 @@
---- libsndio/Makefile.in.orig 2017-11-14 19:00:10 UTC
+--- libsndio/Makefile.in.orig 2018-01-13 12:32:33 UTC
+++ libsndio/Makefile.in
-@@ -14,7 +14,7 @@ LDADD = @ldadd@
- SO_CFLAGS = -fPIC
+@@ -42,8 +42,8 @@ MAN7 = sndio.7
+ #
+ # libraries to build and install
+ #
+-MAJ = 7
+-MIN = 0
++MAJ = 6
++MIN = 1
+ SO = @so@
+ SO_LINK = @so_link@
- # extra compiler flags to produce a shared library with the given name
--SO_LDFLAGS = -shared #-Wl,-soname=libsndio.so.${MAJ}.${MIN}
-+SO_LDFLAGS = -shared -Wl,-soname=libsndio.so.${MAJ}.${MIN}
-
- # variables defined on configure script command line (if any)
- @vars@