aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-09-01 12:16:03 +0800
committeredwin <edwin@FreeBSD.org>2003-09-01 12:16:03 +0800
commit96c6c6865804f62c2443b65186c5474644efdf6b (patch)
tree5b354b52b17d964f1431a11470f86d2010a6ff80 /audio
parent0e861cd1df5a955eb47f1896819f248a4f1b3d86 (diff)
downloadfreebsd-ports-gnome-96c6c6865804f62c2443b65186c5474644efdf6b.tar.gz
freebsd-ports-gnome-96c6c6865804f62c2443b65186c5474644efdf6b.tar.zst
freebsd-ports-gnome-96c6c6865804f62c2443b65186c5474644efdf6b.zip
New port: audio/streamtuner-python 0.0.1
This is streamtuner-python, a streamtuner plugin offering an embedded Python interpreter. PR: ports/48890 Submitted by: Jean-Yves Lefort <jylefort@brutele.be>
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/streamtuner-python/Makefile27
-rw-r--r--audio/streamtuner-python/distinfo1
-rw-r--r--audio/streamtuner-python/pkg-descr7
-rw-r--r--audio/streamtuner-python/pkg-plist15
5 files changed, 51 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 27b8ad86ad90..dedf6f80a182 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -288,6 +288,7 @@
SUBDIR += streamtuner
SUBDIR += streamtuner-live365
SUBDIR += streamtuner-local
+ SUBDIR += streamtuner-python
SUBDIR += sweep
SUBDIR += swhplugins
SUBDIR += tclmidi
diff --git a/audio/streamtuner-python/Makefile b/audio/streamtuner-python/Makefile
new file mode 100644
index 000000000000..8569b07de61e
--- /dev/null
+++ b/audio/streamtuner-python/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: streamtuner-python
+# Date created: 03 Mar 2002
+# Whom: Jean-Yves Lefort <jylefort@brutele.be>
+#
+# $FreeBSD$
+#
+
+PORTNAME= python
+PORTVERSION= 0.0.2
+CATEGORIES= audio www
+MASTER_SITES= http://savannah.nongnu.org/download/streamtuner/streamtuner-python.pkg/${PORTVERSION}/
+PKGNAMEPREFIX= streamtuner-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= jylefort@brutele.be
+COMMENT= A streamtuner plugin providing a Python interpreter
+
+BUILD_DEPENDS= ${X11BASE}/include/streamtuner/streamtuner.h:${PORTSDIR}/audio/streamtuner
+RUN_DEPENDS= ${X11BASE}/bin/streamtuner:${PORTSDIR}/audio/streamtuner
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_PYTHON= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/audio/streamtuner-python/distinfo b/audio/streamtuner-python/distinfo
new file mode 100644
index 000000000000..ffc6a363daff
--- /dev/null
+++ b/audio/streamtuner-python/distinfo
@@ -0,0 +1 @@
+MD5 (streamtuner-python-0.0.2.tar.gz) = aa6067f94be48b163f0d8ea57e397264
diff --git a/audio/streamtuner-python/pkg-descr b/audio/streamtuner-python/pkg-descr
new file mode 100644
index 000000000000..1eb43d9927f9
--- /dev/null
+++ b/audio/streamtuner-python/pkg-descr
@@ -0,0 +1,7 @@
+streamtuner-python is a streamtuner plugin providing an embedded
+Python interpreter.
+
+WWW: http://www.nongnu.org/streamtuner/plugins/
+
+- Jean-Yves Lefort
+jylefort@brutele.be
diff --git a/audio/streamtuner-python/pkg-plist b/audio/streamtuner-python/pkg-plist
new file mode 100644
index 000000000000..2e1aeb987eb3
--- /dev/null
+++ b/audio/streamtuner-python/pkg-plist
@@ -0,0 +1,15 @@
+lib/streamtuner/plugins/python.a
+lib/streamtuner/plugins/python.la
+lib/streamtuner/plugins/python.so
+share/streamtuner-python/icons/google-stations.png
+share/streamtuner-python/modules/G.py
+share/streamtuner-python/modules/G.pyc
+share/streamtuner-python/modules/G.pyo
+share/streamtuner-python/modules/ST.py
+share/streamtuner-python/modules/ST.pyc
+share/streamtuner-python/modules/ST.pyo
+share/streamtuner-python/scripts/google-stations.py
+@dirrm share/streamtuner-python/icons
+@dirrm share/streamtuner-python/modules
+@dirrm share/streamtuner-python/scripts
+@dirrm share/streamtuner-python