aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2015-02-17 11:17:57 +0800
committervanilla <vanilla@FreeBSD.org>2015-02-17 11:17:57 +0800
commita51ebd3ab778a00f4947f520f5cc3e0838423083 (patch)
tree55e2863485b7023baf6c25a233423c80e8d004ce /audio
parentb49d00d202518249dcaa85aff021a300e4502174 (diff)
downloadfreebsd-ports-gnome-a51ebd3ab778a00f4947f520f5cc3e0838423083.tar.gz
freebsd-ports-gnome-a51ebd3ab778a00f4947f520f5cc3e0838423083.tar.zst
freebsd-ports-gnome-a51ebd3ab778a00f4947f520f5cc3e0838423083.zip
Upgrade to 6.04.
PR: 197416 Submitted by: Ports Fury.
Diffstat (limited to 'audio')
-rw-r--r--audio/csound6/Makefile14
-rw-r--r--audio/csound6/distinfo4
-rw-r--r--audio/csound6/files/patch-H__remote.h14
-rw-r--r--audio/csound6/files/patch-Top-csound.c25
-rw-r--r--audio/csound6/pkg-plist5
5 files changed, 36 insertions, 26 deletions
diff --git a/audio/csound6/Makefile b/audio/csound6/Makefile
index 8e14b33a753c..f67cc3c20af7 100644
--- a/audio/csound6/Makefile
+++ b/audio/csound6/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= csound
-PORTVERSION= 6.03.2
-PORTREVISION= 3
+PORTVERSION= 6.04
CATEGORIES= audio lang
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}6/${PORTNAME:S/c/C/}${PORTVERSION:R}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}6/${PORTNAME:S/c/C/}${PORTVERSION}
PKGNAMESUFFIX= 6
DISTNAME= ${PORTNAME:S/c/C/}${PORTVERSION}
DIST_SUBDIR= csound
@@ -51,9 +50,10 @@ CURL_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
CURL_CMAKE_OFF= -DUSE_CURL:BOOL=OFF
DSSI_DESC= Build DSSI/LADSPA host opcodes
DSSI_BUILD_DEPENDS= dssi>0:${PORTSDIR}/audio/dssi
-DSSI_LIB_DEPENDS= libasound.so:${PORTSDIR}/audio/alsa-lib
+DSSI_LIB_DEPENDS= libdssialsacompat.so:${PORTSDIR}/audio/libdssialsacompat
DSSI_RUN_DEPENDS= dssi>0:${PORTSDIR}/audio/dssi
DSSI_CMAKE_OFF= -DBUILD_DSSI_OPCODES:BOOL=OFF
+DSSI_CFLAGS= -isystem ${LOCALBASE}/include/dssi
FLTK_DESC= Build FLTK plugin and GUI
FLTK_LIB_DEPENDS= libfltk.so:${PORTSDIR}/x11-toolkits/fltk
FLTK_CMAKE_ON= -DBUILD_WINSOUND:BOOL=ON
@@ -83,7 +83,7 @@ OSC_DESC= Build OSC opcodes
OSC_LIB_DEPENDS= liblo.so:${PORTSDIR}/audio/liblo
OSC_CMAKE_OFF= -DBUILD_OSC_OPCODES:BOOL=OFF
PNG_DESC= Build Image opcodes
-PNG_LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
+PNG_LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
PNG_CMAKE_OFF= -DBUILD_IMAGE_OPCODES:BOOL=OFF
PORTAUDIO_DESC= Build PortAudio I/O module
PORTAUDIO_BUILD_DEPENDS=portaudio2>0:${PORTSDIR}/audio/portaudio2
@@ -102,6 +102,10 @@ BUILD_DEPENDS+= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
CMAKE_ARGS+= -DFLEX_EXECUTABLE:STRING="${LOCALBASE}/bin/flex"
.endif
+.if ${PORT_OPTIONS:MALSA} && ${PORT_OPTIONS:MDSSI}
+IGNORE= ALSA and DSSI options are mutually exclusive
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
'/-O3/s|^|#| ; \
diff --git a/audio/csound6/distinfo b/audio/csound6/distinfo
index 41aa992a013c..20770b88963e 100644
--- a/audio/csound6/distinfo
+++ b/audio/csound6/distinfo
@@ -1,2 +1,2 @@
-SHA256 (csound/Csound6.03.2.tar.gz) = f5f8364e0bc10aba473800e66176c08ac32b43ca69ad02dc9554bad54e91d170
-SIZE (csound/Csound6.03.2.tar.gz) = 24571513
+SHA256 (csound/Csound6.04.tar.gz) = 0ff0203b87d10779dca962292a407e15ab0b284b558c9c63f892b74ed1e06080
+SIZE (csound/Csound6.04.tar.gz) = 23959744
diff --git a/audio/csound6/files/patch-H__remote.h b/audio/csound6/files/patch-H__remote.h
new file mode 100644
index 000000000000..bdb25b3883d1
--- /dev/null
+++ b/audio/csound6/files/patch-H__remote.h
@@ -0,0 +1,14 @@
+--- H/remote.h.orig
++++ H/remote.h
+@@ -37,7 +37,10 @@
+ #ifdef MACOSX
+ #include <net/if.h>
+ #endif
+- #ifdef LINUX
++ #ifdef __FreeBSD__
++ #include <net/if.h>
++ #endif
++ #ifdef linux
+ #include <linux/if.h>
+ #endif
+ #include <arpa/inet.h>
diff --git a/audio/csound6/files/patch-Top-csound.c b/audio/csound6/files/patch-Top-csound.c
index 409b3b3b17e8..2d07331e63e1 100644
--- a/audio/csound6/files/patch-Top-csound.c
+++ b/audio/csound6/files/patch-Top-csound.c
@@ -1,11 +1,11 @@
---- Top/csound.c.orig 2011-10-16 22:59:03.000000000 +0900
-+++ Top/csound.c 2011-12-07 01:15:33.000000000 +0900
+--- Top/csound.c.orig
++++ Top/csound.c
@@ -60,10 +60,13 @@
#include "cs_par_dispatch.h"
#include "csound_orc_semantics.h"
--#if defined(linux) || defined(__HAIKU__) || defined(EMSCRIPTEN)
-+#if defined(linux) || defined(__HAIKU__) || defined(__FreeBSD__) || defined(EMSCRIPTEN)
+-#if defined(linux) || defined(__HAIKU__) || defined(__EMSCRIPTEN__)
++#if defined(linux) || defined(__HAIKU__) || defined(__FreeBSD__) || defined(__EMSCRIPTEN__)
#define PTHREAD_SPINLOCK_INITIALIZER 0
#endif
@@ -15,17 +15,8 @@
#if defined(USE_OPENMP)
#include <omp.h>
#endif /* USE_OPENMP */
-@@ -919,7 +922,7 @@
-
- #if defined(ANDROID) || (!defined(LINUX) && !defined(SGI) && \
- !defined(__HAIKU__) && !defined(__BEOS__) && \
-- !defined(__MACH__))
-+ !defined(__MACH__) && !defined(__FreeBSD__))
- static char *signal_to_string(int sig)
- {
- switch(sig) {
-@@ -3420,7 +3423,7 @@
- /* ------------------------------------ */
+@@ -3469,7 +3473,7 @@
+ /* ------------------------------------ */
#if defined(HAVE_RDTSC)
-#if !(defined(LINUX) && defined(__GNUC__) && defined(__i386__))
@@ -33,7 +24,7 @@
#undef HAVE_RDTSC
#endif
#endif
-@@ -3433,6 +3436,13 @@
+@@ -3482,6 +3486,13 @@
static int getTimeResolution(void)
{
#if defined(HAVE_RDTSC)
@@ -47,7 +38,7 @@
FILE *f;
char buf[256];
-@@ -3468,9 +3478,14 @@
+@@ -3517,9 +3528,14 @@
}
}
fclose(f);
diff --git a/audio/csound6/pkg-plist b/audio/csound6/pkg-plist
index 82277343cdb3..87bb7b01525c 100644
--- a/audio/csound6/pkg-plist
+++ b/audio/csound6/pkg-plist
@@ -23,7 +23,6 @@ bin/pv_import
bin/pvanal
bin/pvlook
bin/scale
-bin/scope
bin/scot
bin/scsort
bin/sdif2ad
@@ -47,7 +46,6 @@ include/csound/csound_standard_types.h
include/csound/csound_type_system.h
include/csound/cwindow.h
include/csound/filebuilding.h
-@comment include/csound/float-version-double.h
include/csound/float-version.h
include/csound/interlocks.h
include/csound/msg_attr.h
@@ -61,12 +59,14 @@ include/csound/version.h
lib/csound/plugins-6.0/csladspa.so
%%LUA%%lib/csound/plugins-6.0/libLuaCsound.so
lib/csound/plugins-6.0/libampmidid.so
+lib/csound/plugins-6.0/libbuchla.so
lib/csound/plugins-6.0/libcellular.so
lib/csound/plugins-6.0/libchua.so
lib/csound/plugins-6.0/libcontrol.so
lib/csound/plugins-6.0/libcs_date.so
lib/csound/plugins-6.0/libdoppler.so
%%DSSI%%lib/csound/plugins-6.0/libdssi4cs.so
+lib/csound/plugins-6.0/libexciter.so
lib/csound/plugins-6.0/libfareygen.so
%%FLUIDSYNTH%%lib/csound/plugins-6.0/libfluidOpcodes.so
lib/csound/plugins-6.0/libfractalnoise.so
@@ -106,6 +106,7 @@ lib/libcsound64.so.6.0
%%FLTK%%%%PYTHON_SITELIBDIR%%/_CsoundAC.so
%%PYTHON_SITELIBDIR%%/_csnd6.so
%%PYTHON_SITELIBDIR%%/csnd6.py
+%%PYTHON_SITELIBDIR%%/icsound.py
%%NLS%%share/locale/de/LC_MESSAGES/csound6.mo
%%NLS%%share/locale/en_US/LC_MESSAGES/csound6.mo
%%NLS%%share/locale/es_CO/LC_MESSAGES/csound6.mo