aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2005-09-25 23:22:25 +0800
committermi <mi@FreeBSD.org>2005-09-25 23:22:25 +0800
commitb447db20945ba4ff3f7cb91e7b76b9d0aa8e5cb6 (patch)
treefb8a8a4c6549c8099bc497152216ffb9814ce65e /audio
parent15aa42123c89f3e448306505aba7fdb6af5035d1 (diff)
downloadfreebsd-ports-gnome-b447db20945ba4ff3f7cb91e7b76b9d0aa8e5cb6.tar.gz
freebsd-ports-gnome-b447db20945ba4ff3f7cb91e7b76b9d0aa8e5cb6.tar.zst
freebsd-ports-gnome-b447db20945ba4ff3f7cb91e7b76b9d0aa8e5cb6.zip
Append ${LOCALBASE}/include/libarc to CPPFLAGS instead of CONFIGURE_ENV directly
to avoid being overruled by the GNUGETOPT's CPPFLAGS settings on 4.x systems. [1] Continue using GMAKE on systems before 5.0, due to a bug in our make there. Reported by: dhw [1]
Diffstat (limited to 'audio')
-rw-r--r--audio/timidity++/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/audio/timidity++/Makefile b/audio/timidity++/Makefile
index 764c0a217db0..c0ee2cef2b56 100644
--- a/audio/timidity++/Makefile
+++ b/audio/timidity++/Makefile
@@ -24,7 +24,6 @@ CONFLICTS= timidity-0.*
# If you don't have X11, type "make -DWITHOUT_X11" or uncomment this.
#WITHOUT_X11= yes
-#USE_GMAKE= yes
USE_BZIP2= yes
USE_GETOPT_LONG=yes
WANT_GNOME= yes
@@ -34,7 +33,8 @@ EXTRACT_AFTER_ARGS=| ${TAR} -xpf - --exclude '*/libarc/*' \
CONFIGURE_ARGS?=--enable-interface=ncurses,vt100,server
CONFIGURE_ARGS+=--program-transform-name= --enable-network
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include/libarc"
+CPPFLAGS+= -I${LOCALBASE}/include/libarc
+CONFIGURE_ENV+= "CPPFLAGS=${CPPFLAGS}"
PLIST_SUB= EUCJP_LOCALE=${EUCJP_LOCALE} TIMID_LIBDIR=${TIMID_LIBDIR} \
ELISPDIR=share/emacs/site-lisp
@@ -46,6 +46,10 @@ TIMID_LIBDIR= lib/timidity
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+USE_GMAKE= yes
+.endif
+
.if ${.CURDIR} == ${MASTERDIR}
MANLANG= "" ja
MAN1= timidity.1