aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-02-08 22:12:20 +0800
committerkrion <krion@FreeBSD.org>2004-02-08 22:12:20 +0800
commitba729131555edc3d4b608a057466fa50efa485d2 (patch)
tree055277655550460a9661479c3ff6677c855822aa /audio
parentac5e1577aa057967d441d35af71b0558ee199216 (diff)
downloadfreebsd-ports-gnome-ba729131555edc3d4b608a057466fa50efa485d2.tar.gz
freebsd-ports-gnome-ba729131555edc3d4b608a057466fa50efa485d2.tar.zst
freebsd-ports-gnome-ba729131555edc3d4b608a057466fa50efa485d2.zip
- Update to version 1.2.6
PR: ports/62526 Submitted by: Ports Fury
Diffstat (limited to 'audio')
-rw-r--r--audio/mhwaveedit/Makefile12
-rw-r--r--audio/mhwaveedit/distinfo4
-rw-r--r--audio/mhwaveedit/files/patch-src::datasource.c12
3 files changed, 6 insertions, 22 deletions
diff --git a/audio/mhwaveedit/Makefile b/audio/mhwaveedit/Makefile
index eb9142ec0b82..a46b280851bb 100644
--- a/audio/mhwaveedit/Makefile
+++ b/audio/mhwaveedit/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= mhwaveedit
-PORTVERSION= 1.2.5
-PORTREVISION= 1
+PORTVERSION= 1.2.6
CATEGORIES= audio
MASTER_SITES= http://www.mtek.chalmers.se/~hjormagn/
@@ -18,17 +17,17 @@ COMMENT= A graphical program for editing sound files
LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile \
portaudio.0:${PORTSDIR}/audio/portaudio
-USE_REINPLACE= yes
USE_GNOME= gnomehack gnometarget gtk20
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --without-sdl
+CONFIGURE_ARGS= --disable-optimization --without-sdl
+
+PLIST_FILES= bin/mhwaveedit
.if defined(WITH_DOUBLE_SAMPLES)
CONFIGURE_ARGS+= --with-double-samples
.endif
-PLIST_FILES= bin/mhwaveedit
pre-everything::
@${ECHO_MSG} ""
@@ -40,7 +39,4 @@ pre-everything::
@${ECHO_MSG} " quality for 24/32-bit samplerates)"
@${ECHO_MSG} ""
-post-patch:
- @${REINPLACE_CMD} -e 's| -O2||g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/audio/mhwaveedit/distinfo b/audio/mhwaveedit/distinfo
index e98ea3cac2ef..81f7742f78fa 100644
--- a/audio/mhwaveedit/distinfo
+++ b/audio/mhwaveedit/distinfo
@@ -1,2 +1,2 @@
-MD5 (mhwaveedit-1.2.5.tar.gz) = 86559970adc4dca26c7631a135682a11
-SIZE (mhwaveedit-1.2.5.tar.gz) = 220945
+MD5 (mhwaveedit-1.2.6.tar.gz) = 7b824345b21b4f98dbbc487551c6cbf9
+SIZE (mhwaveedit-1.2.6.tar.gz) = 223379
diff --git a/audio/mhwaveedit/files/patch-src::datasource.c b/audio/mhwaveedit/files/patch-src::datasource.c
deleted file mode 100644
index 9213f316e593..000000000000
--- a/audio/mhwaveedit/files/patch-src::datasource.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/datasource.c.orig Tue Dec 23 07:06:26 2003
-+++ src/datasource.c Sat Dec 27 00:59:02 2003
-@@ -212,8 +212,8 @@
-
- Datasource *datasource_byteswap(Datasource *source)
- {
-- if (source == NULL) return NULL;
- Datasource *ds;
-+ if (source == NULL) return NULL;
- ds = gtk_type_new(datasource_get_type());
- ds->type = DATASOURCE_BYTESWAP;
- memcpy(&(ds->format),&(source->format),sizeof(Dataformat));