aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2013-11-10 03:13:27 +0800
committerrene <rene@FreeBSD.org>2013-11-10 03:13:27 +0800
commitbc9eaafddac55414d201b6636e63508ce80779b9 (patch)
tree7436338612f22a81def9ee6c2d2e3826c1504ea4 /audio
parent74e9373bcd181bd5e011c695cd6ff38aeea7d44b (diff)
downloadfreebsd-ports-gnome-bc9eaafddac55414d201b6636e63508ce80779b9.tar.gz
freebsd-ports-gnome-bc9eaafddac55414d201b6636e63508ce80779b9.tar.zst
freebsd-ports-gnome-bc9eaafddac55414d201b6636e63508ce80779b9.zip
Convert to USES=kmod, which removes duplicated code and ensures that all
required steps are followed. There are no user-visible changes. The exception is multimedia/ptx-kmod, which now installs the kernel module into /boot/modules instead of ${PREFIX}/libexec/${PORTNAME}, this was something USES=kmod cannot handle. PR: ports/183625 Submitted by: myself Approved by: portmgr (bdrewery) Exp-run by: bdrewery
Diffstat (limited to 'audio')
-rw-r--r--audio/aureal-kmod/Makefile14
-rw-r--r--audio/aureal-kmod/pkg-plist11
2 files changed, 7 insertions, 18 deletions
diff --git a/audio/aureal-kmod/Makefile b/audio/aureal-kmod/Makefile
index 6a6c6ae73975..366414cf94e1 100644
--- a/audio/aureal-kmod/Makefile
+++ b/audio/aureal-kmod/Makefile
@@ -4,7 +4,7 @@
PORTNAME= aureal
PORTVERSION= 1.5
PORTREVISION= 6
-CATEGORIES= audio kld
+CATEGORIES= audio
MASTER_SITES= GOOGLE_CODE
PROJECTHOST= ${PORTNAME}-snd
PKGNAMESUFFIX= -kmod
@@ -26,24 +26,19 @@ USE_RC_SUBR= ${PORTNAME}
SUB_FILES= pkg-message
SUB_LIST= KMODDIR=${KMODDIR}
-PLIST_SUB= KMODDIR=${KMODDIR_REL}
-
WRKSRC= ${WRKDIR}
MAKE_ENV= WRKSRC="${WRKSRC}"
MAKE_ARGS= KMODDIR="${KMODDIR}"
+USES= kmod
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 800000
EXTRA_PATCHES+= ${PATCHDIR}/extra_800000_patch-au88x0.c
.endif
-# Make sure kernel sources are present before going any further
-.if ! exists(${SRC_BASE}/sys/dev/sound/pcm/sound.c)
-IGNORE= you need to extract kernel source tree before building this package
-.endif
-
pre-everything::
.for STRAY in ${STRAYFILES}
.if exists(${SRC_BASE}/sys/dev/sound/pci/${STRAY})
@@ -61,9 +56,6 @@ pre-everything::
.endif
.endfor
-pre-install:
- ${MKDIR} ${KMODDIR}
-
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/audio/aureal-kmod/pkg-plist b/audio/aureal-kmod/pkg-plist
index e2b8fecdde3e..eb84e5e3a8d9 100644
--- a/audio/aureal-kmod/pkg-plist
+++ b/audio/aureal-kmod/pkg-plist
@@ -1,8 +1,5 @@
-@unexec `if [ -e /bin/chflags ]; then echo /bin/chflags; else echo /usr/bin/chflags; fi` noschg %D/%%KMODDIR%%/snd_au88?0.ko
-@unexec kldxref %D/%%KMODDIR%%
-@unexec rm -f %D/%%KMODDIR%%/linker.hints
-%%KMODDIR%%/snd_au8810.ko
-%%KMODDIR%%/snd_au8820.ko
-%%KMODDIR%%/snd_au8830.ko
-@dirrmtry %%KMODDIR%%
+@unexec `if [ -e /bin/chflags ]; then echo /bin/chflags; else echo /usr/bin/chflags; fi` noschg /%%KMODDIR%%/snd_au88?0.ko
+/%%KMODDIR%%/snd_au8810.ko
+/%%KMODDIR%%/snd_au8820.ko
+/%%KMODDIR%%/snd_au8830.ko
@dirrmtry modules