aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2003-02-12 06:06:54 +0800
committerarved <arved@FreeBSD.org>2003-02-12 06:06:54 +0800
commitc383a28127a6c6b56a81efce56815559ae03f92c (patch)
tree632986b54fb34f27fa4788f4d4c5bb892dadff52 /audio
parentfb4a3ea103f7e490625e12f84dd04abca04a81c3 (diff)
downloadfreebsd-ports-gnome-c383a28127a6c6b56a81efce56815559ae03f92c.tar.gz
freebsd-ports-gnome-c383a28127a6c6b56a81efce56815559ae03f92c.tar.zst
freebsd-ports-gnome-c383a28127a6c6b56a81efce56815559ae03f92c.zip
Respect CFLAGS
Diffstat (limited to 'audio')
-rw-r--r--audio/ladspa/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/audio/ladspa/Makefile b/audio/ladspa/Makefile
index 60cacd281766..1c1e91fe1661 100644
--- a/audio/ladspa/Makefile
+++ b/audio/ladspa/Makefile
@@ -21,10 +21,10 @@ PLUGIN_FILES= amp.so delay.so filter.so noise.so sine.so
PLUGIN_DIR?= ${PREFIX}/lib/ladspa/
post-patch:
- ${REINPLACE_CMD} -e 's,-ldl,,' ${WRKSRC}/src/makefile
+ ${REINPLACE_CMD} -e 's,-ldl,,; s,^CFLAGS[ \t]=,#CFLAGS+=,' ${WRKSRC}/src/makefile
do-build:
- cd ${WRKSRC}/src; ${GMAKE} -f makefile targets
+ cd ${WRKSRC}/src; ${SETENV} ${MAKE_ENV} ${GMAKE} -f makefile targets
do-install:
@${INSTALL_DATA} ${WRKSRC}/src/ladspa.h ${PREFIX}/include