aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-03-26 22:00:52 +0800
committerbapt <bapt@FreeBSD.org>2013-03-26 22:00:52 +0800
commitccadbd5d96aa06da564a8144dfbe82be9005a29f (patch)
treec2a3d2d03d5b242825ceb3f140189c7e85b23e99 /audio
parent7a284f40f9e7fbff14aaca6fe1585dab33fcc776 (diff)
downloadfreebsd-ports-gnome-ccadbd5d96aa06da564a8144dfbe82be9005a29f.tar.gz
freebsd-ports-gnome-ccadbd5d96aa06da564a8144dfbe82be9005a29f.tar.zst
freebsd-ports-gnome-ccadbd5d96aa06da564a8144dfbe82be9005a29f.zip
Fix after conversion to new options framework
Approved by: miwi
Diffstat (limited to 'audio')
-rw-r--r--audio/shntool/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/audio/shntool/Makefile b/audio/shntool/Makefile
index bbaf873e4046..c5db0ded4f3d 100644
--- a/audio/shntool/Makefile
+++ b/audio/shntool/Makefile
@@ -32,14 +32,14 @@ RDEP= AIFF:sox SHN:shorten FLAC APE:mac OFR:ofr:optimfrog LPAC WV:wavpack \
.include <bsd.port.options.mk>
-.for i in ${RDEP}
-o= ${i:C/:.*//}
-. if ${PORT_OPTIONS:M${o}}
-b= ${i:C/^[A-Z]*://:C/:.*//:L}
-p= ${i:C/^[A-Z]*://:C/.*://:L}
+.for o in ${PORT_OPTIONS}
+m= ${RDEP:M${o}*}
+.if ${m}
+b= ${m:C/^[A-Z]*://:C/:.*//:L}
+p= ${m:C/^[A-Z]*://:C/.*://:L}
RUN_DEPENDS+= ${b}:${PORTSDIR}/audio/${p}
RUN_DEPENDS:= ${RUN_DEPENDS}
-. endif
+.endif
.endfor
.include <bsd.port.mk>