aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-10-06 01:02:45 +0800
committergarga <garga@FreeBSD.org>2005-10-06 01:02:45 +0800
commitcda734eef7492f54cfa25cff99b69acc42e3bc51 (patch)
tree83d3addb303fa2aa57a5e9513062b22207a1b018 /audio
parent9e0e86865e56f324afa9472ef0cbfcec54a119d3 (diff)
downloadfreebsd-ports-gnome-cda734eef7492f54cfa25cff99b69acc42e3bc51.tar.gz
freebsd-ports-gnome-cda734eef7492f54cfa25cff99b69acc42e3bc51.tar.zst
freebsd-ports-gnome-cda734eef7492f54cfa25cff99b69acc42e3bc51.zip
pysdl_mixer is a python interface to SDL's sdl_mixer.
This is usefull for multichannel sample and music playback from python. This project is currently being used by soya (https://gna.org/projects/soya/). WWW: https://gna.org/projects/pysdlmixer/ PR: ports/86927 Submitted by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/py-sdl_mixer/Makefile39
-rw-r--r--audio/py-sdl_mixer/distinfo2
-rw-r--r--audio/py-sdl_mixer/pkg-descr5
-rw-r--r--audio/py-sdl_mixer/pkg-plist8
5 files changed, 55 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 88edb1a2473e..1cca1f2642ac 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -389,6 +389,7 @@
SUBDIR += py-musicbrainz
SUBDIR += py-ogg
SUBDIR += py-openal
+ SUBDIR += py-sdl_mixer
SUBDIR += py-vorbis
SUBDIR += py-xmms
SUBDIR += pysol-sound-server
diff --git a/audio/py-sdl_mixer/Makefile b/audio/py-sdl_mixer/Makefile
new file mode 100644
index 000000000000..0fed3eb34625
--- /dev/null
+++ b/audio/py-sdl_mixer/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: pysdl_mixer
+# Date created: 2005-10-05
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sdl_mixer
+PORTVERSION= 0.0.3
+CATEGORIES= audio python
+MASTER_SITES= http://download.gna.org/pysdlmixer/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pysdl_mixer-${PORTVERSION}
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Pysdl_mixer is a python interface to SDL's sdl_mixer
+
+LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal
+
+DIST_SUBDIR= python
+USE_GZIP= yes
+USE_SDL= sdl mixer
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+USE_REINPLACE= yes
+WRKSRC= ${WRKDIR}/pysdl_mixer-${PORTVERSION}
+EXAMPLESDIR= ${PREFIX}/share/examples/py-sdl-mixer
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,"SDL","SDL-1.1",g' ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} -e 's,SDL/SDL,SDL11/SDL,g' ${WRKSRC}/sdl_mixer.c
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/py-sdl_mixer/distinfo b/audio/py-sdl_mixer/distinfo
new file mode 100644
index 000000000000..11f4f9a0455c
--- /dev/null
+++ b/audio/py-sdl_mixer/distinfo
@@ -0,0 +1,2 @@
+MD5 (python/pysdl_mixer-0.0.3.tar.gz) = 81d109f02938c6a1c368dd461252450a
+SIZE (python/pysdl_mixer-0.0.3.tar.gz) = 24133
diff --git a/audio/py-sdl_mixer/pkg-descr b/audio/py-sdl_mixer/pkg-descr
new file mode 100644
index 000000000000..179a1ef749ee
--- /dev/null
+++ b/audio/py-sdl_mixer/pkg-descr
@@ -0,0 +1,5 @@
+pysdl_mixer is a python interface to SDL's sdl_mixer.
+This is usefull for multichannel sample and music playback from python.
+This project is currently being used by soya (https://gna.org/projects/soya/).
+
+WWW: https://gna.org/projects/pysdlmixer/
diff --git a/audio/py-sdl_mixer/pkg-plist b/audio/py-sdl_mixer/pkg-plist
new file mode 100644
index 000000000000..999232056aec
--- /dev/null
+++ b/audio/py-sdl_mixer/pkg-plist
@@ -0,0 +1,8 @@
+lib/%%PYTHON_VERSION%%/site-packages/pysdl_mixer/__init__.py
+lib/%%PYTHON_VERSION%%/site-packages/pysdl_mixer/__init__.pyc
+lib/%%PYTHON_VERSION%%/site-packages/pysdl_mixer/__init__.pyo
+lib/%%PYTHON_VERSION%%/site-packages/pysdl_mixer/sdl_mixer.so
+%%PORTDOCS%%%%EXAMPLESDIR%%/sdl_mixer-1.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/test.wav
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+@dirrm lib/%%PYTHON_VERSION%%/site-packages/pysdl_mixer