aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-09 05:19:56 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-09 05:19:56 +0800
commitce2227845c8ec5a70034ce220a82d39ead5ad9e4 (patch)
treea5a4ebd3cb2732115b316e36162f925ba41e7529 /audio
parent7a99691102229f72ae77e1c05f82564c423a5b2e (diff)
downloadfreebsd-ports-gnome-ce2227845c8ec5a70034ce220a82d39ead5ad9e4.tar.gz
freebsd-ports-gnome-ce2227845c8ec5a70034ce220a82d39ead5ad9e4.tar.zst
freebsd-ports-gnome-ce2227845c8ec5a70034ce220a82d39ead5ad9e4.zip
- Fully support staging (there were some ${STAGEDIR} statements but NO_STAGE
was still defined) - also strip binaries and shared objects
Diffstat (limited to 'audio')
-rw-r--r--audio/espeak/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/audio/espeak/Makefile b/audio/espeak/Makefile
index be951c8a6a4a..c587c956ba09 100644
--- a/audio/espeak/Makefile
+++ b/audio/espeak/Makefile
@@ -33,7 +33,6 @@ MAKE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
CXXFLAGS+= -I${LOCALBASE}/include
USES= gmake
-NO_STAGE= yes
USE_LDCONFIG= yes
USE_ZIP= yes
@@ -66,5 +65,7 @@ post-patch:
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libespeak.so*
.include <bsd.port.mk>