aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2010-05-14 13:41:11 +0800
committermva <mva@FreeBSD.org>2010-05-14 13:41:11 +0800
commite664a48a601255a6a53da7fc886d749be0728667 (patch)
tree465c27bb98537ea8780f88b9796b090613ad5e26 /audio
parent423edd1007579106ce12da47703928ef40478e29 (diff)
downloadfreebsd-ports-gnome-e664a48a601255a6a53da7fc886d749be0728667.tar.gz
freebsd-ports-gnome-e664a48a601255a6a53da7fc886d749be0728667.tar.zst
freebsd-ports-gnome-e664a48a601255a6a53da7fc886d749be0728667.zip
- Update to 0.9.9
Diffstat (limited to 'audio')
-rw-r--r--audio/py-fastaudio/Makefile1
-rw-r--r--audio/py-fastaudio/files/patch-fastaudio.pyx13
2 files changed, 12 insertions, 2 deletions
diff --git a/audio/py-fastaudio/Makefile b/audio/py-fastaudio/Makefile
index d51e2d36202b..a11b5737c29c 100644
--- a/audio/py-fastaudio/Makefile
+++ b/audio/py-fastaudio/Makefile
@@ -8,6 +8,7 @@
PORTNAME= fastaudio
PORTVERSION= 0.1
+PORTREVISION= 1
CATEGORIES= audio python
MASTER_SITES= http://www.freenet.org.nz/python/pyPortAudio/:site1 \
http://www.portaudio.com/archives/:site2
diff --git a/audio/py-fastaudio/files/patch-fastaudio.pyx b/audio/py-fastaudio/files/patch-fastaudio.pyx
index 8f097b13b3f0..025b6aaacfb5 100644
--- a/audio/py-fastaudio/files/patch-fastaudio.pyx
+++ b/audio/py-fastaudio/files/patch-fastaudio.pyx
@@ -1,5 +1,5 @@
---- fastaudio.pyx.orig 2004-06-15 20:37:39.000000000 +0900
-+++ fastaudio.pyx 2009-06-06 18:54:52.000000000 +0900
+--- fastaudio.pyx.orig 2004-06-15 13:37:39.000000000 +0200
++++ fastaudio.pyx 2010-05-08 09:24:38.000000000 +0200
@@ -92,7 +92,7 @@
#@+node:portaudio.h
# portaudio-specifics
@@ -9,6 +9,15 @@
ctypedef int PaError
cdef enum PA_ERRORS:
+@@ -553,7 +553,7 @@
+ cdef int isrunning
+ #@-node:attributes
+ #@+node:__new__
+- def __new__(self, samplerate=8000, channels=2, format='int16', framesPerBuf=4096, maxbufs=16, **kwds):
++ def __cinit__(self, samplerate=8000, channels=2, format='int16', framesPerBuf=4096, maxbufs=16, **kwds):
+ """
+ Constructor for fastaudio stream objects.
+
@@ -586,8 +586,8 @@
cdata.framesPerBuf = framesPerBuf
cdata.bytesPerFrame = channels * _sampleFormatSizes[format]