aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2014-09-17 22:05:17 +0800
committerfeld <feld@FreeBSD.org>2014-09-17 22:05:17 +0800
commiteacef976cca078d7a830bca01c08e2f01b490ffe (patch)
tree7141c122abcf6d5a759cdabf31a711afa60027f4 /audio
parent58a76e71e5747d6b449952e3bd0196a2dd4173be (diff)
downloadfreebsd-ports-gnome-eacef976cca078d7a830bca01c08e2f01b490ffe.tar.gz
freebsd-ports-gnome-eacef976cca078d7a830bca01c08e2f01b490ffe.tar.zst
freebsd-ports-gnome-eacef976cca078d7a830bca01c08e2f01b490ffe.zip
Update to 1.2.8
Add USE_LDCONFIG per portlint Add LICENSE Utilize PORTVERSION in pkg-plist to limit number of required changes
Diffstat (limited to 'audio')
-rw-r--r--audio/mumble/Makefile8
-rw-r--r--audio/mumble/distinfo4
-rw-r--r--audio/mumble/files/patch-src__mumble__VoiceRecorderDialog.cpp11
-rw-r--r--audio/mumble/pkg-plist2
4 files changed, 9 insertions, 16 deletions
diff --git a/audio/mumble/Makefile b/audio/mumble/Makefile
index ec0a516d1515..47143063e151 100644
--- a/audio/mumble/Makefile
+++ b/audio/mumble/Makefile
@@ -2,14 +2,15 @@
# $FreeBSD$
PORTNAME= mumble
-PORTVERSION= 1.2.6
-PORTREVISION= 1
+PORTVERSION= 1.2.8
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/Mumble/${PORTVERSION}
MAINTAINER= feld@FreeBSD.org
COMMENT= Voice chat software primarily intended for use while gaming
+LICENSE= BSD3CLAUSE
+
LIB_DEPENDS+= libspeex.so:${PORTSDIR}/audio/speex \
libsndfile.so:${PORTSDIR}/audio/libsndfile \
libboost_iostreams.so:${PORTSDIR}/devel/boost-libs \
@@ -17,7 +18,10 @@ LIB_DEPENDS+= libspeex.so:${PORTSDIR}/audio/speex \
libprotoc.so:${PORTSDIR}/devel/protobuf \
libopus.so:${PORTSDIR}/audio/opus
+PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+
USES= gmake pkgconfig qmake
+USE_LDCONFIG= yes
USE_QT4= gui svg iconengines_run xml sql network l10n \
linguist_build moc_build rcc_build uic_build \
opengl sql-sqlite3_run
diff --git a/audio/mumble/distinfo b/audio/mumble/distinfo
index aea3f86e9d2f..833abcb14e7e 100644
--- a/audio/mumble/distinfo
+++ b/audio/mumble/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mumble-1.2.6.tar.gz) = 876cdecfb89798ab45020cdae0d64bd0fa899a9a97c2c7f4a6e706d4165fb6ff
-SIZE (mumble-1.2.6.tar.gz) = 3201577
+SHA256 (mumble-1.2.8.tar.gz) = 4c2fc3dff49687bc1d977905958e8a9c35e109723aeed42c9ea124104febe159
+SIZE (mumble-1.2.8.tar.gz) = 3202518
diff --git a/audio/mumble/files/patch-src__mumble__VoiceRecorderDialog.cpp b/audio/mumble/files/patch-src__mumble__VoiceRecorderDialog.cpp
deleted file mode 100644
index 2dd42fa79d75..000000000000
--- a/audio/mumble/files/patch-src__mumble__VoiceRecorderDialog.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/mumble/VoiceRecorderDialog.cpp.orig 2013-06-01 21:16:32.000000000 +0000
-+++ ./src/mumble/VoiceRecorderDialog.cpp 2013-10-12 02:38:45.441221500 +0000
-@@ -38,7 +38,7 @@
- #include "ServerHandler.h"
- #include "VoiceRecorder.h"
-
--VoiceRecorderDialog::VoiceRecorderDialog(QWidget *p = NULL) : QDialog(p), qtTimer(new QTimer(this)) {
-+VoiceRecorderDialog::VoiceRecorderDialog(QWidget *p) : QDialog(p), qtTimer(new QTimer(this)) {
- qtTimer->setObjectName(QLatin1String("qtTimer"));
- qtTimer->setInterval(200);
- setupUi(this);
diff --git a/audio/mumble/pkg-plist b/audio/mumble/pkg-plist
index 6e8d4b8dcea3..2c654b5f8c65 100644
--- a/audio/mumble/pkg-plist
+++ b/audio/mumble/pkg-plist
@@ -4,7 +4,7 @@ lib/libcelt-mumble.so.0.7.0
lib/libmumble.so
lib/libmumble.so.1
lib/libmumble.so.1.2
-lib/libmumble.so.1.2.6
+lib/libmumble.so.%%PORTVERSION%%
man/man1/mumble.1.gz
share/applications/mumble.desktop
share/icons/hicolor/128x128/apps/mumble.png