aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-03-31 03:20:22 +0800
committerkrion <krion@FreeBSD.org>2004-03-31 03:20:22 +0800
commitec7e839df6339ee2ce45b2a86705d36babd6ddb2 (patch)
tree89a2307095c132bb20ec384fd75a853ff48669ed /audio
parent919d5d370736760e6caa8a55aa6ec939d3387eec (diff)
downloadfreebsd-ports-gnome-ec7e839df6339ee2ce45b2a86705d36babd6ddb2.tar.gz
freebsd-ports-gnome-ec7e839df6339ee2ce45b2a86705d36babd6ddb2.tar.zst
freebsd-ports-gnome-ec7e839df6339ee2ce45b2a86705d36babd6ddb2.zip
- Use USE_ICONV knob
Approved by: portmgr
Diffstat (limited to 'audio')
-rw-r--r--audio/flac/Makefile4
-rw-r--r--audio/id3lib/Makefile3
-rw-r--r--audio/mpg123/Makefile2
-rw-r--r--audio/mpiosh/Makefile2
-rw-r--r--audio/musicpd/Makefile2
5 files changed, 6 insertions, 7 deletions
diff --git a/audio/flac/Makefile b/audio/flac/Makefile
index eb5b2bdcfd9c..45a11c03798f 100644
--- a/audio/flac/Makefile
+++ b/audio/flac/Makefile
@@ -15,13 +15,13 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= naddy@FreeBSD.org
COMMENT= Free lossless audio codec
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv \
- ogg.5:${PORTSDIR}/audio/libogg
+LIB_DEPENDS= ogg.5:${PORTSDIR}/audio/libogg
.if ${MACHINE_ARCH} == "i386"
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
.endif
+USE_ICONV= yes
USE_REINPLACE= yes
USE_LIBTOOL_VER= 13
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
diff --git a/audio/id3lib/Makefile b/audio/id3lib/Makefile
index d6f83230e34d..89d443352b41 100644
--- a/audio/id3lib/Makefile
+++ b/audio/id3lib/Makefile
@@ -15,8 +15,7 @@ PORTREVISION= 1
MAINTAINER= ports@oven.org
COMMENT= Library for manipulating ID3v1/v1.1 and ID3v2 tags
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
-
+USE_ICONV= yes
USE_LIBTOOL_VER= 13
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
diff --git a/audio/mpg123/Makefile b/audio/mpg123/Makefile
index d114a982f164..fc57819f21f5 100644
--- a/audio/mpg123/Makefile
+++ b/audio/mpg123/Makefile
@@ -31,7 +31,7 @@ MAKE_ARGS+= WITH_ICONV=yes
.if defined(DEFAULT_RECODE)
MAKE_ARGS+= DEFAULT_RECODE=${DEFAULT_RECODE}
.endif
-LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
+USE_ICONV= yes
.endif
.if defined(WITH_NAS)
diff --git a/audio/mpiosh/Makefile b/audio/mpiosh/Makefile
index 35772aec2cf0..f89c08da84a2 100644
--- a/audio/mpiosh/Makefile
+++ b/audio/mpiosh/Makefile
@@ -16,10 +16,10 @@ MAINTAINER= asa@gascom.ru
COMMENT= Digit@lway MPIO MP3 player tool
RUN_DEPENDS= ${MODULES}/mpio.ko:${PORTSDIR}/audio/mpio-driver
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
MODULES?= /modules
+USE_ICONV= yes
USE_LIBTOOL_VER= 13
USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index 70a66acb6b59..8582d52c2608 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -69,7 +69,7 @@ CONFIGURE_ARGS+=--disable-aac
.ifdef(WITHOUT_ICONV)
CONFIGURE_ARGS+=--disable-iconv
.else
-LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
+USE_ICONV= yes
.endif
.ifdef(WITHOUT_IPV6)