aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authortrasz <trasz@FreeBSD.org>2009-08-27 14:07:56 +0800
committertrasz <trasz@FreeBSD.org>2009-08-27 14:07:56 +0800
commitf6f68a1a78727e94beea12d97d839a579c268e61 (patch)
tree2b1ead146766f1ce2256f30d6fae4e4aaff945f3 /audio
parente8f2d042399235d99d4b545f359af1fbd465bece (diff)
downloadfreebsd-ports-gnome-f6f68a1a78727e94beea12d97d839a579c268e61.tar.gz
freebsd-ports-gnome-f6f68a1a78727e94beea12d97d839a579c268e61.tar.zst
freebsd-ports-gnome-f6f68a1a78727e94beea12d97d839a579c268e61.zip
The Calf project aims at providing a set of high quality open source
audio plugins for musicians. All the included plugins are designed to be used with multitrack software, as software replacement for instruments and guitar stomp boxes. The plugins are available in following formats: - DSSI (both synthesizers and effects, GTK+ GUI is included) - Standalone JACK client application with GTK+-based GUI - LADSPA (only effect plugins, GUI not available unless host supports DSSI-style GUI for LADSPA), with LRDF. Note that use of LADSPA is strongly discouraged, as the limitations of the standard may cause serious inconvenience. WWW: http://calf.sourceforge.net/
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/calf/Makefile37
-rw-r--r--audio/calf/distinfo3
-rw-r--r--audio/calf/pkg-descr17
-rw-r--r--audio/calf/pkg-plist30
5 files changed, 88 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 2877d2110627..bdedf71f1b9a 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -79,6 +79,7 @@
SUBDIR += bonk
SUBDIR += boodler
SUBDIR += btc
+ SUBDIR += calf
SUBDIR += cam
SUBDIR += cantus
SUBDIR += cantus_3
diff --git a/audio/calf/Makefile b/audio/calf/Makefile
new file mode 100644
index 000000000000..fa15974410b7
--- /dev/null
+++ b/audio/calf/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: calf
+# Date created: 2009-08-26
+# Whom: <trasz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= calf
+PORTVERSION= 0.0.18.5
+CATEGORIES= audio
+MASTER_SITES= SF
+
+MAINTAINER= trasz@FreeBSD.org
+COMMENT= Calf audio plugin pack
+
+LIB_DEPENDS= dssialsacompat.0:${PORTSDIR}/audio/libdssialsacompat \
+ lo.7:${PORTSDIR}/audio/liblo \
+ jack.0:${PORTSDIR}/audio/jack \
+ lash.2:${PORTSDIR}/audio/lash
+BUILD_DEPENDS= ${LOCALBASE}/include/dssi.h:${PORTSDIR}/audio/dssi \
+ ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20 libglade2
+CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/dssi -L${LOCALBASE}/lib
+
+MAN1= calfjackhost.1
+MAN7= calf.7
+INSTALLS_ICONS= yes
+
+post-patch:
+ @${FIND} ${BUILD_WRKSRC} -name '*.cpp' | ${XARGS} \
+ ${REINPLACE_CMD} -e "s|<malloc.h>|<stdlib.h>|g"
+
+.include <bsd.port.mk>
diff --git a/audio/calf/distinfo b/audio/calf/distinfo
new file mode 100644
index 000000000000..9c86aa38045c
--- /dev/null
+++ b/audio/calf/distinfo
@@ -0,0 +1,3 @@
+MD5 (calf-0.0.18.5.tar.gz) = b844eac59bb16354b8dc25a15a0576f6
+SHA256 (calf-0.0.18.5.tar.gz) = e25d69f1b949a952d78d51b992fdeb8e1d5d746ca632797bc5622fe246ceafe1
+SIZE (calf-0.0.18.5.tar.gz) = 583875
diff --git a/audio/calf/pkg-descr b/audio/calf/pkg-descr
new file mode 100644
index 000000000000..7eed0c77a594
--- /dev/null
+++ b/audio/calf/pkg-descr
@@ -0,0 +1,17 @@
+The Calf project aims at providing a set of high quality open source
+audio plugins for musicians. All the included plugins are designed
+to be used with multitrack software, as software replacement for
+instruments and guitar stomp boxes.
+
+The plugins are available in following formats:
+
+ - DSSI (both synthesizers and effects, GTK+ GUI is included)
+
+ - Standalone JACK client application with GTK+-based GUI
+
+ - LADSPA (only effect plugins, GUI not available unless host supports
+ DSSI-style GUI for LADSPA), with LRDF. Note that use of LADSPA
+ is strongly discouraged, as the limitations of the standard may cause
+ serious inconvenience.
+
+WWW: http://calf.sourceforge.net/
diff --git a/audio/calf/pkg-plist b/audio/calf/pkg-plist
new file mode 100644
index 000000000000..d8f520c19782
--- /dev/null
+++ b/audio/calf/pkg-plist
@@ -0,0 +1,30 @@
+bin/calfjackhost
+lib/ladspa/calf.so
+lib/dssi/calf/calf_gtk
+lib/dssi/calf.so
+share/calf/presets.xml
+share/calf/knob.png
+share/calf/gui-filter.xml
+share/calf/gui-filterclavier.xml
+share/calf/gui-flanger.xml
+share/calf/gui-reverb.xml
+share/calf/gui-monosynth.xml
+share/calf/gui-vintagedelay.xml
+share/calf/gui-organ.xml
+share/calf/gui-rotaryspeaker.xml
+share/calf/gui-phaser.xml
+share/calf/gui-multichorus.xml
+share/calf/gui-compressor.xml
+share/calf/calf.glade
+share/ladspa/rdf/calf.rdf
+share/icons/hicolor/16x16/apps/calf.png
+share/icons/hicolor/24x24/apps/calf.png
+share/icons/hicolor/32x32/apps/calf.png
+share/icons/hicolor/48x48/apps/calf.png
+share/icons/hicolor/icon-theme.cache
+share/applications/calf.desktop
+@dirrm lib/dssi/calf
+@dirrm share/calf
+@dirrmtry share/ladspa/rdf
+@dirrmtry share/ladspa
+@dirrmtry share/applications