aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2016-03-23 02:11:08 +0800
committernovel <novel@FreeBSD.org>2016-03-23 02:11:08 +0800
commit040e95a1383dafab7825b57dabff74d345009eaf (patch)
tree2f9f874193ec03321d271b2f2b651eaec66fd335 /audio
parent16771ef44fd0c9cc89413b12c018961ffcbce3b7 (diff)
downloadfreebsd-ports-gnome-040e95a1383dafab7825b57dabff74d345009eaf.tar.gz
freebsd-ports-gnome-040e95a1383dafab7825b57dabff74d345009eaf.tar.zst
freebsd-ports-gnome-040e95a1383dafab7825b57dabff74d345009eaf.zip
audio/deadbeef: update to 0.7.1
Also, drop some patches merged upstream. Reviewed by: mat Approved by: vg (maintainer) via IRC Differential Revision: D5676
Diffstat (limited to 'audio')
-rw-r--r--audio/deadbeef/Makefile5
-rw-r--r--audio/deadbeef/distinfo4
-rw-r--r--audio/deadbeef/files/patch-plugins_artwork_artwork__internal.h10
-rw-r--r--audio/deadbeef/files/patch-plugins_artwork_cache.c12
4 files changed, 4 insertions, 27 deletions
diff --git a/audio/deadbeef/Makefile b/audio/deadbeef/Makefile
index e8c8e5ee34f4..6c2345c06cb1 100644
--- a/audio/deadbeef/Makefile
+++ b/audio/deadbeef/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= deadbeef
-PORTVERSION= 0.7.0
+PORTVERSION= 0.7.1
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/
@@ -20,8 +20,7 @@ CONFIGURE_ARGS= --disable-alsa --disable-nullout --disable-static
CPPFLAGS+= -I../dumb/dumb-kode54/include -I../../plugins/libmp4ff \
-I../../plugins/gme/game-music-emu-0.6pre \
-I./sidplay-libs/libsidplay/include/sidplay \
- -I${LOCALBASE}/include \
- -D__POSIX_VISIBLE
+ -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib -lexecinfo -lintl
USE_GNOME= intltool
INSTALLS_ICONS= yes
diff --git a/audio/deadbeef/distinfo b/audio/deadbeef/distinfo
index c71379e9d30c..f03fe7cada8f 100644
--- a/audio/deadbeef/distinfo
+++ b/audio/deadbeef/distinfo
@@ -1,2 +1,2 @@
-SHA256 (deadbeef-0.7.0.tar.bz2) = 1dab69d00695b830724dfd8aa38f5cab851dbd02a3d95bce8b7720fdc38dd868
-SIZE (deadbeef-0.7.0.tar.bz2) = 4765372
+SHA256 (deadbeef-0.7.1.tar.bz2) = dc7f9e124d98baa77af2648e86ac807dc458f33b72d0792fb8be206e95085734
+SIZE (deadbeef-0.7.1.tar.bz2) = 4764841
diff --git a/audio/deadbeef/files/patch-plugins_artwork_artwork__internal.h b/audio/deadbeef/files/patch-plugins_artwork_artwork__internal.h
deleted file mode 100644
index 57c6229786dc..000000000000
--- a/audio/deadbeef/files/patch-plugins_artwork_artwork__internal.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- plugins/artwork/artwork_internal.h.orig 2015-07-15 07:06:25 UTC
-+++ plugins/artwork/artwork_internal.h
-@@ -24,6 +24,7 @@
- #ifndef __ARTWORK_INTERNAL_H
- #define __ARTWORK_INTERNAL_H
-
-+#include <limits.h>
- #include "../../deadbeef.h"
-
- #define min(x,y) ((x)<(y)?(x):(y))
diff --git a/audio/deadbeef/files/patch-plugins_artwork_cache.c b/audio/deadbeef/files/patch-plugins_artwork_cache.c
deleted file mode 100644
index 6e097bce6e2f..000000000000
--- a/audio/deadbeef/files/patch-plugins_artwork_cache.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- plugins/artwork/cache.c.orig 2016-01-02 20:28:08 UTC
-+++ plugins/artwork/cache.c
-@@ -160,7 +160,8 @@ cache_cleaner_thread(void *none)
- usleep(100000);
- deadbeef->mutex_lock(thread_mutex);
- }
-- closedir(covers_dir);
-+ if (covers_dir)
-+ closedir(covers_dir);
-
- /* Sleep until just after the oldest file expires */
- if (cache_expiry_seconds > 0 && !terminate) {