aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2015-08-19 04:00:22 +0800
committerpgollucci <pgollucci@FreeBSD.org>2015-08-19 04:00:22 +0800
commit93365b6842ffb967f06a538f4b580072bf0c1554 (patch)
tree8661e40c86678b5a90eb568ad2913d0fe0fb0891 /audio
parent6633f434c01af96cfcd69c77f44a60839cbe6a99 (diff)
downloadfreebsd-ports-gnome-93365b6842ffb967f06a538f4b580072bf0c1554.tar.gz
freebsd-ports-gnome-93365b6842ffb967f06a538f4b580072bf0c1554.tar.zst
freebsd-ports-gnome-93365b6842ffb967f06a538f4b580072bf0c1554.zip
audio/mous: qt4-linguist -> qt4-linguisttools
- USE_QT4=linguist -> USE_QT4=linguisttools_build. Also, add 'corelib'. - Add USE_LDCONFIG. - Regenerate patches. - Bump PORTREVISION PR: 201684 Submitted by: s3erios@gmail.com Approved by: shen.elf@gmail.com
Diffstat (limited to 'audio')
-rw-r--r--audio/mous/Makefile6
-rw-r--r--audio/mous/files/patch-CMakeLists.txt8
-rw-r--r--audio/mous/files/patch-contrib__ffmpeg-strip-wma__common.h6
3 files changed, 11 insertions, 9 deletions
diff --git a/audio/mous/Makefile b/audio/mous/Makefile
index 44d701ae0b18..22ff08a56172 100644
--- a/audio/mous/Makefile
+++ b/audio/mous/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mous
PORTVERSION= 1.1a
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= http://cloud.github.com/downloads/bsdelf/mous/
@@ -14,6 +14,7 @@ LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
USES= cmake
+USE_LDCONFIG= yes
OPTIONS_DEFINE= ALSA ASSEMBLY FAAC FAAD FLAC LAME AO CUE MAC4DECODER \
MACDECODER MPG123 NCURSES OSS QT4 SDK TAGLIB VORBIS \
@@ -81,7 +82,8 @@ OSS_CMAKE_ON= -DWithPluginOssRenderer=1
OSS_CMAKE_OFF= -DWithPluginOssRenderer=0
QT4_DESC= QT4 frontend
-QT4_USE= QT4=gui,linguist,moc_build,qmake_build,rcc_build,uic_build
+QT4_USE= QT4=corelib,gui,linguisttools_build
+QT4_USE+= QT4=qmake_build,moc_build,rcc_build,uic_build
QT4_CMAKE_ON= -DWithFrontendQt=1
QT4_CMAKE_OFF= -DWithFrontendQt=0
diff --git a/audio/mous/files/patch-CMakeLists.txt b/audio/mous/files/patch-CMakeLists.txt
index a0aaf22051bc..16fac8bbd568 100644
--- a/audio/mous/files/patch-CMakeLists.txt
+++ b/audio/mous/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2012-06-15 04:46:40.000000000 +0200
-+++ CMakeLists.txt 2012-07-18 17:04:03.462575000 +0200
-@@ -292,7 +292,7 @@
+--- CMakeLists.txt.orig 2012-06-28 14:58:11 UTC
++++ CMakeLists.txt
+@@ -306,7 +306,7 @@ if(WithFrontendQt)
RUNTIME DESTINATION bin)
install(
CODE "file(GLOB TRANSLATION_FILES \"${PROJECT_BINARY_DIR}/*.qm\")"
@@ -9,7 +9,7 @@
)
endif()
-@@ -307,7 +307,7 @@
+@@ -321,7 +321,7 @@ install(
)
file(GLOB RESOURCE_FILES "${MOUS_SOURCE_DIR}/resource/*")
diff --git a/audio/mous/files/patch-contrib__ffmpeg-strip-wma__common.h b/audio/mous/files/patch-contrib__ffmpeg-strip-wma__common.h
index 9d7b40052a8e..74fc198e38e8 100644
--- a/audio/mous/files/patch-contrib__ffmpeg-strip-wma__common.h
+++ b/audio/mous/files/patch-contrib__ffmpeg-strip-wma__common.h
@@ -1,6 +1,6 @@
---- ./contrib/ffmpeg-strip-wma/common.h.orig 2014-07-02 10:52:02.000000000 -0400
-+++ ./contrib/ffmpeg-strip-wma/common.h 2014-07-02 10:52:39.000000000 -0400
-@@ -1150,11 +1150,6 @@
+--- contrib/ffmpeg-strip-wma/common.h.orig 2012-06-28 14:58:11 UTC
++++ contrib/ffmpeg-strip-wma/common.h
+@@ -1150,11 +1150,6 @@ if(256*256*256*64%(tcount+tskip_count)==
#define CLAMP_TO_8BIT(d) ((d > 0xff) ? 0xff : (d < 0) ? 0 : d)