aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2016-08-08 19:18:50 +0800
committerehaupt <ehaupt@FreeBSD.org>2016-08-08 19:18:50 +0800
commite7a4ba3ec143a0496f898f01c28e9fd32dabe7f5 (patch)
tree98d133e50b36c81670c96e06ec597480fd694110 /audio
parent869df77e1d6d7c0bffd92e8b6f7da5f0d0e84f84 (diff)
downloadfreebsd-ports-gnome-e7a4ba3ec143a0496f898f01c28e9fd32dabe7f5.tar.gz
freebsd-ports-gnome-e7a4ba3ec143a0496f898f01c28e9fd32dabe7f5.tar.zst
freebsd-ports-gnome-e7a4ba3ec143a0496f898f01c28e9fd32dabe7f5.zip
- Strip library
- Register gettext-runtime USES - Register glib12, gtk12 with USE_GNOME - Register x11, xext, xi with USE_XORG
Diffstat (limited to 'audio')
-rw-r--r--audio/xmms-nsf/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/audio/xmms-nsf/Makefile b/audio/xmms-nsf/Makefile
index bf08263fd00b..5d55fa7e1832 100644
--- a/audio/xmms-nsf/Makefile
+++ b/audio/xmms-nsf/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xmms-nsf
PORTVERSION= 0.0.3
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= audio
MASTER_SITES= http://optronic.sourceforge.net/files/ \
LOCAL/ehaupt
@@ -17,7 +17,9 @@ BUILD_DEPENDS= xmms:multimedia/xmms
RUN_DEPENDS= xmms:multimedia/xmms
GNU_CONFIGURE= yes
-USES= libtool
+USES= gettext-runtime libtool
+USE_GNOME= glib12 gtk12
+USE_XORG= x11 xext xi
USE_LDCONFIG= yes
USE_CSTD= gnu89
CONFIGURE_ARGS= --disable-static --with-pic
@@ -33,4 +35,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|<malloc\.h>|<stdlib.h>|' \
${WRKSRC}/src/nes/nestypes.h
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/xmms/Input/libnsf.so
+
.include <bsd.port.mk>