aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-01-09 06:38:25 +0800
committersat <sat@FreeBSD.org>2007-01-09 06:38:25 +0800
commit82cb5d792b21a78c3f11290e99ae526d10630046 (patch)
tree2cd002d2a7fb551a0de14c6f3e9c9e42f5ba65a2 /audio
parent2e18e0dd89cf0115e3f2ada0cb4fb54756c4c371 (diff)
downloadfreebsd-ports-gnome-82cb5d792b21a78c3f11290e99ae526d10630046.tar.gz
freebsd-ports-gnome-82cb5d792b21a78c3f11290e99ae526d10630046.tar.zst
freebsd-ports-gnome-82cb5d792b21a78c3f11290e99ae526d10630046.zip
- Update to 3.99.4.5
- Take maintainership - Better amd64 support - Drop static lib - Backward compatibility has been abandoned - Miscellaneous tweaks
Diffstat (limited to 'audio')
-rw-r--r--audio/mac/Makefile31
-rw-r--r--audio/mac/distinfo6
-rw-r--r--audio/mac/files/patch-long-pointers114
-rw-r--r--audio/mac/files/patch-src-MACLib-APEInfo.cpp11
-rw-r--r--audio/mac/files/patch-src-MACLib-APETag.cpp20
-rw-r--r--audio/mac/files/patch-src-MACLib-MACLib.cpp20
-rw-r--r--audio/mac/files/patch-src-MACLib-WAVInputSource.cpp11
-rw-r--r--audio/mac/files/patch-src-Shared-NoWindows.h11
-rw-r--r--audio/mac/files/patch-src__MACLib__APEDecompress.cpp11
-rw-r--r--audio/mac/pkg-plist22
10 files changed, 40 insertions, 217 deletions
diff --git a/audio/mac/Makefile b/audio/mac/Makefile
index 77032221afca..090ed0c29c29 100644
--- a/audio/mac/Makefile
+++ b/audio/mac/Makefile
@@ -1,28 +1,24 @@
-# New ports collection makefile for: mac
-# Date created: 8 Aug 2004
-# Whom: dieringe
+# New ports collection makefile for: mac
+# Date created: 8 Aug 2004
+# Whom: dieringe
#
# $FreeBSD$
#
PORTNAME= mac
-PORTVERSION= 3.99.4.4
-PORTREVISION= 1
+PORTVERSION= 3.99.4.5
CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= mac-port
-DISTNAME= ${PORTNAME}-3.99-u4-b4
+MASTER_SITES= SF/mac-port
+DISTNAME= ${PORTNAME}-3.99-u4-b5
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Monkey's Audio lossless audio (de)compressor
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Monkey's Audio lossless codec
-BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
+BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm
-USE_GMAKE= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --enable-backward
-
-INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --disable-static
.include <bsd.port.pre.mk>
@@ -31,6 +27,9 @@ IGNORE= does not compile on 4.x due to missing multibyte string functions in li
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-s -O3||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-O3||' ${WRKSRC}/configure
+# @${REINPLACE_CMD} -e '/GetInfo/s|intptr_t|long|g' ${WRKSRC}/src/MACLib/*.*
+# @${REINPLACE_CMD} -e 's|wcsnicmp|wcsncmp|g;s|wcsicmp|wcscmp|g;s|_wcsicmp|wcscmp|g;s|\.__pos||g' \
+# ${WRKSRC}/src/MACLib/*.* ${WRKSRC}/src/Shared/*.*
.include <bsd.port.post.mk>
diff --git a/audio/mac/distinfo b/audio/mac/distinfo
index cfb41ee9889a..5af3258f669b 100644
--- a/audio/mac/distinfo
+++ b/audio/mac/distinfo
@@ -1,3 +1,3 @@
-MD5 (mac-3.99-u4-b4.tar.gz) = 7eab2b9cc4bb696452d6c147976294b5
-SHA256 (mac-3.99-u4-b4.tar.gz) = 707e03533ccf66adbbc5bae1f97d98804882af57fdfee6238320f56a53a6639d
-SIZE (mac-3.99-u4-b4.tar.gz) = 435442
+MD5 (mac-3.99-u4-b5.tar.gz) = 75716b342e07deae58f56a2522362006
+SHA256 (mac-3.99-u4-b5.tar.gz) = d59ac5b1fa375a78eadbd5d9bb638ad0229185b42b562dbb04b0dab6475b6651
+SIZE (mac-3.99-u4-b5.tar.gz) = 421234
diff --git a/audio/mac/files/patch-long-pointers b/audio/mac/files/patch-long-pointers
deleted file mode 100644
index 167c8929508f..000000000000
--- a/audio/mac/files/patch-long-pointers
+++ /dev/null
@@ -1,114 +0,0 @@
-diff -ru --exclude Makefile --exclude *.Plo orig/work/mac-3.99-u4-b4/src/MACLib/APEDecompress.cpp mac/work/mac-3.99-u4-b4/src/MACLib/APEDecompress.cpp
---- src/MACLib/APEDecompress.cpp Sun Jul 3 16:31:35 2005
-+++ src/MACLib/APEDecompress.cpp Mon Nov 28 02:05:18 2005
-@@ -23,7 +23,7 @@
- }
-
- // get format information
-- GetInfo(APE_INFO_WAVEFORMATEX, (int) &m_wfeInput);
-+ GetInfo(APE_INFO_WAVEFORMATEX, (long) &m_wfeInput);
- m_nBlockAlign = GetInfo(APE_INFO_BLOCK_ALIGN);
-
- // initialize other stuff
-@@ -367,7 +367,7 @@
- /*****************************************************************************************
- Get information from the decompressor
- *****************************************************************************************/
--int CAPEDecompress::GetInfo(APE_DECOMPRESS_FIELDS Field, int nParam1, int nParam2)
-+int CAPEDecompress::GetInfo(APE_DECOMPRESS_FIELDS Field, long nParam1, int nParam2)
- {
- int nRetVal = 0;
- BOOL bHandled = TRUE;
-diff -ru --exclude Makefile --exclude *.Plo orig/work/mac-3.99-u4-b4/src/MACLib/APEDecompress.h mac/work/mac-3.99-u4-b4/src/MACLib/APEDecompress.h
---- src/MACLib/APEDecompress.h Thu Mar 10 13:36:25 2005
-+++ src/MACLib/APEDecompress.h Mon Nov 28 02:05:37 2005
-@@ -22,7 +22,7 @@
- int GetData(char * pBuffer, int nBlocks, int * pBlocksRetrieved);
- int Seek(int nBlockOffset);
-
-- int GetInfo(APE_DECOMPRESS_FIELDS Field, int nParam1 = 0, int nParam2 = 0);
-+ int GetInfo(APE_DECOMPRESS_FIELDS Field, long nParam1 = 0, int nParam2 = 0);
-
- protected:
-
-diff -ru --exclude Makefile --exclude *.Plo orig/work/mac-3.99-u4-b4/src/MACLib/APEInfo.cpp mac/work/mac-3.99-u4-b4/src/MACLib/APEInfo.cpp
---- src/MACLib/APEInfo.cpp Mon Nov 28 02:15:38 2005
-+++ src/MACLib/APEInfo.cpp Mon Nov 28 02:13:29 2005
-@@ -129,7 +129,7 @@
- /*****************************************************************************************
- Primary query function
- *****************************************************************************************/
--int CAPEInfo::GetInfo(APE_DECOMPRESS_FIELDS Field, int nParam1, int nParam2)
-+int CAPEInfo::GetInfo(APE_DECOMPRESS_FIELDS Field, long nParam1, int nParam2)
- {
- int nRetVal = -1;
-
-@@ -254,7 +254,7 @@
- }
- else
- {
-- WAVEFORMATEX wfeFormat; GetInfo(APE_INFO_WAVEFORMATEX, (int) &wfeFormat, 0);
-+ WAVEFORMATEX wfeFormat; GetInfo(APE_INFO_WAVEFORMATEX, (long) &wfeFormat, 0);
- WAVE_HEADER WAVHeader; FillWaveHeader(&WAVHeader, m_APEFileInfo.nWAVDataBytes, &wfeFormat,
- m_APEFileInfo.nWAVTerminatingBytes);
- memcpy(pBuffer, &WAVHeader, sizeof(WAVE_HEADER));
-diff -ru --exclude Makefile --exclude *.Plo orig/work/mac-3.99-u4-b4/src/MACLib/APEInfo.h mac/work/mac-3.99-u4-b4/src/MACLib/APEInfo.h
---- src/MACLib/APEInfo.h Thu Mar 10 13:36:25 2005
-+++ src/MACLib/APEInfo.h Mon Nov 28 02:13:35 2005
-@@ -82,7 +82,7 @@
- virtual ~CAPEInfo();
-
- // query for information
-- int GetInfo(APE_DECOMPRESS_FIELDS Field, int nParam1 = 0, int nParam2 = 0);
-+ int GetInfo(APE_DECOMPRESS_FIELDS Field, long nParam1 = 0, int nParam2 = 0);
-
- private:
-
-diff -ru --exclude Makefile --exclude *.Plo orig/work/mac-3.99-u4-b4/src/MACLib/APESimple.cpp mac/work/mac-3.99-u4-b4/src/MACLib/APESimple.cpp
---- src/MACLib/APESimple.cpp Thu Mar 10 13:36:25 2005
-+++ src/MACLib/APESimple.cpp Mon Nov 28 02:00:57 2005
-@@ -291,7 +291,7 @@
- if (spAPEDecompress == NULL || nFunctionRetVal != ERROR_SUCCESS) throw(nFunctionRetVal);
-
- // get the input format
-- THROW_ON_ERROR(spAPEDecompress->GetInfo(APE_INFO_WAVEFORMATEX, (int) &wfeInput))
-+ THROW_ON_ERROR(spAPEDecompress->GetInfo(APE_INFO_WAVEFORMATEX, (long) &wfeInput))
-
- // allocate space for the header
- spTempBuffer.Assign(new unsigned char [spAPEDecompress->GetInfo(APE_INFO_WAV_HEADER_BYTES)], TRUE);
-diff -ru --exclude Makefile --exclude *.Plo orig/work/mac-3.99-u4-b4/src/MACLib/MACLib.h mac/work/mac-3.99-u4-b4/src/MACLib/MACLib.h
---- src/MACLib/MACLib.h Tue May 31 10:02:27 2005
-+++ src/MACLib/MACLib.h Mon Nov 28 02:06:30 2005
-@@ -259,7 +259,7 @@
- // int nParam2
- // generic parameter... usage is listed in APE_DECOMPRESS_FIELDS
- //////////////////////////////////////////////////////////////////////////////////////////////
-- virtual int GetInfo(APE_DECOMPRESS_FIELDS Field, int nParam1 = 0, int nParam2 = 0) = 0;
-+ virtual int GetInfo(APE_DECOMPRESS_FIELDS Field, long nParam1 = 0, int nParam2 = 0) = 0;
- };
-
- /*************************************************************************************************
-diff -ru --exclude Makefile --exclude *.Plo orig/work/mac-3.99-u4-b4/src/MACLib/Old/APEDecompressOld.cpp mac/work/mac-3.99-u4-b4/src/MACLib/Old/APEDecompressOld.cpp
---- src/MACLib/Old/APEDecompressOld.cpp Fri Mar 11 13:23:37 2005
-+++ src/MACLib/Old/APEDecompressOld.cpp Mon Nov 28 02:11:44 2005
-@@ -165,7 +165,7 @@
- return ERROR_SUCCESS;
- }
-
--int CAPEDecompressOld::GetInfo(APE_DECOMPRESS_FIELDS Field, int nParam1, int nParam2)
-+int CAPEDecompressOld::GetInfo(APE_DECOMPRESS_FIELDS Field, long nParam1, int nParam2)
- {
- int nRetVal = 0;
- BOOL bHandled = TRUE;
-diff -ru --exclude Makefile --exclude *.Plo orig/work/mac-3.99-u4-b4/src/MACLib/Old/APEDecompressOld.h mac/work/mac-3.99-u4-b4/src/MACLib/Old/APEDecompressOld.h
---- src/MACLib/Old/APEDecompressOld.h Thu Mar 10 13:36:26 2005
-+++ src/MACLib/Old/APEDecompressOld.h Mon Nov 28 02:11:54 2005
-@@ -13,7 +13,7 @@
- int GetData(char * pBuffer, int nBlocks, int * pBlocksRetrieved);
- int Seek(int nBlockOffset);
-
-- int GetInfo(APE_DECOMPRESS_FIELDS Field, int nParam1 = 0, int nParam2 = 0);
-+ int GetInfo(APE_DECOMPRESS_FIELDS Field, long nParam1 = 0, int nParam2 = 0);
-
- protected:
-
diff --git a/audio/mac/files/patch-src-MACLib-APEInfo.cpp b/audio/mac/files/patch-src-MACLib-APEInfo.cpp
deleted file mode 100644
index 76151234632e..000000000000
--- a/audio/mac/files/patch-src-MACLib-APEInfo.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/MACLib/APEInfo.cpp.orig Wed May 12 08:07:13 2004
-+++ src/MACLib/APEInfo.cpp Mon Aug 9 20:25:20 2004
-@@ -40,7 +40,7 @@
- // we don't want to analyze right away for non-local files
- // since a single I/O object is shared, we can't tag and read at the same time (i.e. in multiple threads)
- BOOL bAnalyzeNow = TRUE;
-- if ((wcsnicmp(pFilename, L"http://", 7) == 0) || (wcsnicmp(pFilename, L"m01p://", 7) == 0))
-+ if ((wcsncmp(pFilename, L"http://", 7) == 0) || (wcsncmp(pFilename, L"m01p://", 7) == 0))
- bAnalyzeNow = FALSE;
-
- m_spAPETag.Assign(new CAPETag(m_spIO, bAnalyzeNow));
diff --git a/audio/mac/files/patch-src-MACLib-APETag.cpp b/audio/mac/files/patch-src-MACLib-APETag.cpp
deleted file mode 100644
index d9d911b6c48b..000000000000
--- a/audio/mac/files/patch-src-MACLib-APETag.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/MACLib/APETag.cpp.orig Wed May 12 08:10:49 2004
-+++ src/MACLib/APETag.cpp Mon Aug 9 20:26:04 2004
-@@ -310,7 +310,7 @@
-
- for (int z = 0; z < m_nFields; z++)
- {
-- if (wcsicmp(m_aryFields[z]->GetFieldName(), pFieldName) == 0)
-+ if (wcscmp(m_aryFields[z]->GetFieldName(), pFieldName) == 0)
- return z;
- }
-
-@@ -478,7 +478,7 @@
- BOOL bFound = FALSE;
- while ((nGenreIndex < GENRE_COUNT) && (bFound == FALSE))
- {
-- if (_wcsicmp(cBuffer, g_ID3Genre[nGenreIndex]) == 0)
-+ if (wcscmp(cBuffer, g_ID3Genre[nGenreIndex]) == 0)
- {
- pID3Tag->Genre = nGenreIndex;
- bFound = TRUE;
diff --git a/audio/mac/files/patch-src-MACLib-MACLib.cpp b/audio/mac/files/patch-src-MACLib-MACLib.cpp
deleted file mode 100644
index 01ee0a50d942..000000000000
--- a/audio/mac/files/patch-src-MACLib-MACLib.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/MACLib/MACLib.cpp.orig Wed May 4 15:35:33 2005
-+++ src/MACLib/MACLib.cpp Mon Nov 28 01:45:59 2005
-@@ -62,7 +62,7 @@
- pExtension--;
-
- // take the appropriate action (based on the extension)
-- if (wcsicmp(pExtension, L".apl") == 0)
-+ if (wcscmp(pExtension, L".apl") == 0)
- {
- // "link" file (.apl linked large APE file)
- CAPELink APELink(pFilename);
-@@ -72,7 +72,7 @@
- nStartBlock = APELink.GetStartBlock(); nFinishBlock = APELink.GetFinishBlock();
- }
- }
-- else if ((wcsicmp(pExtension, L".mac") == 0) || (wcsicmp(pExtension, L".ape") == 0))
-+ else if ((wcscmp(pExtension, L".mac") == 0) || (wcscmp(pExtension, L".ape") == 0))
- {
- // plain .ape file
- pAPEInfo = new CAPEInfo(&nErrorCode, pFilename);
diff --git a/audio/mac/files/patch-src-MACLib-WAVInputSource.cpp b/audio/mac/files/patch-src-MACLib-WAVInputSource.cpp
deleted file mode 100644
index 8ce3aae98649..000000000000
--- a/audio/mac/files/patch-src-MACLib-WAVInputSource.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/MACLib/WAVInputSource.cpp.orig Wed May 12 06:35:57 2004
-+++ src/MACLib/WAVInputSource.cpp Mon Aug 9 20:27:58 2004
-@@ -47,7 +47,7 @@
- pExtension--;
-
- // create the proper input source
-- if (wcsicmp(pExtension, L".wav") == 0)
-+ if (wcscmp(pExtension, L".wav") == 0)
- {
- if (pErrorCode) *pErrorCode = ERROR_SUCCESS;
- return new CWAVInputSource(pSourceName, pwfeSource, pTotalBlocks, pHeaderBytes, pTerminatingBytes, pErrorCode);
diff --git a/audio/mac/files/patch-src-Shared-NoWindows.h b/audio/mac/files/patch-src-Shared-NoWindows.h
deleted file mode 100644
index 7051635da62c..000000000000
--- a/audio/mac/files/patch-src-Shared-NoWindows.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Shared/NoWindows.h.orig Tue May 3 10:05:03 2005
-+++ src/Shared/NoWindows.h Mon Nov 28 01:47:00 2005
-@@ -65,7 +65,7 @@
-
- #include <locale.h>
-
--#define _FPOSOFF(fp) ((long)(fp).__pos)
-+#define _FPOSOFF(fp) ((long)(fp))
- #define MAX_PATH 260
-
- #ifndef _WAVEFORMATEX_
diff --git a/audio/mac/files/patch-src__MACLib__APEDecompress.cpp b/audio/mac/files/patch-src__MACLib__APEDecompress.cpp
new file mode 100644
index 000000000000..5f3d5f9f0f64
--- /dev/null
+++ b/audio/mac/files/patch-src__MACLib__APEDecompress.cpp
@@ -0,0 +1,11 @@
+--- ./src/MACLib/APEDecompress.cpp.orig Tue Jan 9 01:08:49 2007
++++ ./src/MACLib/APEDecompress.cpp Tue Jan 9 01:09:55 2007
+@@ -369,7 +369,7 @@
+ *****************************************************************************************/
+ intptr_t CAPEDecompress::GetInfo(APE_DECOMPRESS_FIELDS Field, intptr_t nParam1, intptr_t nParam2)
+ {
+- int nRetVal = 0;
++ intptr_t nRetVal = 0;
+ BOOL bHandled = TRUE;
+
+ switch (Field)
diff --git a/audio/mac/pkg-plist b/audio/mac/pkg-plist
index 4e678f8994e2..b3363aa02651 100644
--- a/audio/mac/pkg-plist
+++ b/audio/mac/pkg-plist
@@ -1,13 +1,4 @@
bin/mac
-include/mac/config.h
-include/mac/All.h
-include/mac/GlobalFunctions.h
-include/mac/ID3Genres.h
-include/mac/IO.h
-include/mac/SmartPtr.h
-include/mac/StdLibFileIO.h
-include/mac/NoWindows.h
-include/mac/CharacterHelper.h
include/mac/APECompress.h
include/mac/APECompressCore.h
include/mac/APECompressCreate.h
@@ -16,11 +7,20 @@ include/mac/APEHeader.h
include/mac/APEInfo.h
include/mac/APELink.h
include/mac/APETag.h
+include/mac/All.h
+include/mac/CharacterHelper.h
+include/mac/CircleBuffer.h
+include/mac/GlobalFunctions.h
+include/mac/ID3Genres.h
+include/mac/IO.h
include/mac/MACLib.h
include/mac/MACProgressHelper.h
include/mac/MACUtils.h
-@dirrm include/mac
-lib/libmac.a
+include/mac/NoWindows.h
+include/mac/SmartPtr.h
+include/mac/StdLibFileIO.h
+include/mac/config.h
lib/libmac.la
lib/libmac.so
lib/libmac.so.2
+@dirrm include/mac