aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2007-02-12 02:32:20 +0800
committerskv <skv@FreeBSD.org>2007-02-12 02:32:20 +0800
commit958438407a0c67adf600c4b5efc53a7a3e42e64f (patch)
treeb826bb83d96f54d4123edf10ecd7a5460a3fb6be /audio
parent4ec585992d4fe1f674adad893e8374948bf9d914 (diff)
downloadfreebsd-ports-gnome-958438407a0c67adf600c4b5efc53a7a3e42e64f.tar.gz
freebsd-ports-gnome-958438407a0c67adf600c4b5efc53a7a3e42e64f.tar.zst
freebsd-ports-gnome-958438407a0c67adf600c4b5efc53a7a3e42e64f.zip
Unbreak build.
Pointed by: kris
Diffstat (limited to 'audio')
-rw-r--r--audio/p5-Audio-TagLib/Makefile2
-rw-r--r--audio/p5-Audio-TagLib/files/patch-Makefile.PL35
2 files changed, 11 insertions, 26 deletions
diff --git a/audio/p5-Audio-TagLib/Makefile b/audio/p5-Audio-TagLib/Makefile
index de2ce808d26a..6e2ed7e3725a 100644
--- a/audio/p5-Audio-TagLib/Makefile
+++ b/audio/p5-Audio-TagLib/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
USE_ICONV= YES
PERL_CONFIGURE= YES
-CONFIGURE_ARGS+= CC="${CXX}" LD="${CXX}"
+CONFIGURE_ARGS+= CC="${CXX}" LD="${CXX}" LIBS="-L/usr/local/lib -ltag -liconv"
MAN3= Audio::TagLib.3 Audio::TagLib::APE::Footer.3 \
Audio::TagLib::APE::Item.3 Audio::TagLib::APE::ItemListMap.3 \
diff --git a/audio/p5-Audio-TagLib/files/patch-Makefile.PL b/audio/p5-Audio-TagLib/files/patch-Makefile.PL
index 81341f7d850b..5a29e37ebd8a 100644
--- a/audio/p5-Audio-TagLib/files/patch-Makefile.PL
+++ b/audio/p5-Audio-TagLib/files/patch-Makefile.PL
@@ -1,28 +1,13 @@
---- Makefile.PL.orig Mon Apr 17 15:43:46 2006
-+++ Makefile.PL Tue Jul 4 15:55:49 2006
-@@ -14,13 +14,6 @@
- chomp($libpath);
- our $incpath = $libpath . "/include/taglib";
- $libpath .= -d $libpath. "/lib64" ? "/lib64" : "/lib";
-- my ($lib) = glob($libpath . "/libtag.so.1.4.*");
-- if (defined $lib) {
-- print STDOUT "got $lib, good, go on\n";
-- } else {
-- Carp::croak("version 1.4.* not found,".
-- "please install firstly\n");
-- }
+--- Makefile.PL.orig Wed Jan 17 05:49:27 2007
++++ Makefile.PL Sun Feb 11 21:17:10 2007
+@@ -17,8 +17,8 @@
+ chomp($libver);
+ Carp::croak("Please install taglib ver 1.4.*") unless
+ $libver =~ m/^1\.4/io;
+- our $libs = qx(taglib-config --libs);
+- our $inc = ' -I/usr/include -I./include -I. '. qx(taglib-config --cflags);
++ our $libs = qx(taglib-config --libs); chomp($libs); $libs.=' -liconv';
++ our $inc = ' -I/usr/include -I./include -I. -I$(PREFIX)/include '. qx(taglib-config --cflags);
}
# See lib/ExtUtils/MakeMaker.pm for details of how to influence
-@@ -37,9 +30,9 @@
- LD => 'g++',
- LDDLFLAGS => "-shared -L${libpath}",
- XSOPT => '-C++ -hiertype',
-- LIBS => ['-ltag'], # e.g., '-lm'
-+ LIBS => ['-ltag -liconv'],
- DEFINE => $^O eq 'freebsd' ? '-D_BSD_ICONV -DNO_DOXYGEN' : '-DNO_DOXYGEN', # e.g., '-DHAVE_SOMETHING'
-- INC => "-I${incpath} -I/usr/include -I./include ", # e.g., '-I. -I/usr/include/other'
-+ INC => "-I${incpath} -I/usr/include -I./include -I\$(PREFIX)/include",
- # Un-comment this if you add C files to link with later:
- # OBJECT => '$(O_FILES)', # link all the C files too
- );