aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-04-14 05:12:40 +0800
committerjylefort <jylefort@FreeBSD.org>2005-04-14 05:12:40 +0800
commitcdc4218381a0d1d997136b0f0be345d3c0a9a42d (patch)
tree39382c92384c98c620b36b67b89bb5a663ee2498 /audio
parent45346325f80041b89687ed4fcee82623283bf290 (diff)
downloadfreebsd-ports-gnome-cdc4218381a0d1d997136b0f0be345d3c0a9a42d.tar.gz
freebsd-ports-gnome-cdc4218381a0d1d997136b0f0be345d3c0a9a42d.tar.zst
freebsd-ports-gnome-cdc4218381a0d1d997136b0f0be345d3c0a9a42d.zip
Fixes a crash in the Python plugin.
PR: ports/79201 Submitted by: myself Approved by: adamw (mentor)
Diffstat (limited to 'audio')
-rw-r--r--audio/streamtuner/Makefile2
-rw-r--r--audio/streamtuner/files/patch-src_plugins_python_pst-main.c18
2 files changed, 19 insertions, 1 deletions
diff --git a/audio/streamtuner/Makefile b/audio/streamtuner/Makefile
index 90bb6a3d8b12..d80d7873587e 100644
--- a/audio/streamtuner/Makefile
+++ b/audio/streamtuner/Makefile
@@ -7,7 +7,7 @@
PORTNAME= streamtuner
PORTVERSION= 0.99.99
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio www
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/audio/streamtuner/files/patch-src_plugins_python_pst-main.c b/audio/streamtuner/files/patch-src_plugins_python_pst-main.c
new file mode 100644
index 000000000000..1e51097505b6
--- /dev/null
+++ b/audio/streamtuner/files/patch-src_plugins_python_pst-main.c
@@ -0,0 +1,18 @@
+--- src/plugins/python/pst-main.c.orig Thu Mar 24 15:52:58 2005
++++ src/plugins/python/pst-main.c Thu Mar 24 15:53:59 2005
+@@ -94,6 +94,7 @@
+ {
+ gboolean status = FALSE;
+ PyObject *module;
++ char *argv[] = { "" };
+
+ if (! check_api_version(err))
+ return FALSE;
+@@ -109,6 +110,7 @@
+ }
+
+ Py_Initialize();
++ PySys_SetArgv(G_N_ELEMENTS(argv), argv);
+ PyEval_InitThreads();
+
+ module = PyImport_AddModule("__main__");