aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/blogbench
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-02-15 05:04:04 +0800
committerpav <pav@FreeBSD.org>2005-02-15 05:04:04 +0800
commitaa7a9d75c47edbd17339b6d8afd7de3831ccd505 (patch)
tree212bf58260431a9ab7ba672fba0d8cff0473bff7 /benchmarks/blogbench
parent01ed9c64b5ce932b118956ec8118a10fb4e07c9c (diff)
downloadfreebsd-ports-gnome-aa7a9d75c47edbd17339b6d8afd7de3831ccd505.tar.gz
freebsd-ports-gnome-aa7a9d75c47edbd17339b6d8afd7de3831ccd505.tar.zst
freebsd-ports-gnome-aa7a9d75c47edbd17339b6d8afd7de3831ccd505.zip
Blogbench is a portable filesystem benchmark that tries to reproduce the
load of a real-world busy file server. It stresses the filesystem with multiple threads performing random reads, writes and rewrites in order to get a realistic idea of the scalability and the concurrency a system can handle. WWW: http://blogbench.pureftpd.org/ PR: ports/77490 Submitted by: Janos Mohacsi <janos.mohacsi@bsd.hu>
Diffstat (limited to 'benchmarks/blogbench')
-rw-r--r--benchmarks/blogbench/Makefile29
-rw-r--r--benchmarks/blogbench/distinfo2
-rw-r--r--benchmarks/blogbench/pkg-descr8
3 files changed, 39 insertions, 0 deletions
diff --git a/benchmarks/blogbench/Makefile b/benchmarks/blogbench/Makefile
new file mode 100644
index 000000000000..8b59e9c8ffdb
--- /dev/null
+++ b/benchmarks/blogbench/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: blogbench
+# Date created: Feb 14, 2005
+# Whom: janos.mohacsi@bsd.hu
+#
+# $FreeBSD$
+#
+
+PORTNAME= blogbench
+PORTVERSION= 1.0
+CATEGORIES= benchmarks
+MASTER_SITES= ftp://ftp.blogbench.pureftpd.org/blogbench/
+
+MAINTAINER= janos.mohacsi@bsd.hu
+COMMENT= Performance Test of Filesystem I/O
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+
+MAN8= blogbench.8
+PLIST_FILES= bin/blogbench
+PORTDOCS= README
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/benchmarks/blogbench/distinfo b/benchmarks/blogbench/distinfo
new file mode 100644
index 000000000000..da09f119a7a0
--- /dev/null
+++ b/benchmarks/blogbench/distinfo
@@ -0,0 +1,2 @@
+MD5 (blogbench-1.0.tar.bz2) = 8b8c0d97cbb9ecc02a4c5f1f7169bece
+SIZE (blogbench-1.0.tar.bz2) = 103355
diff --git a/benchmarks/blogbench/pkg-descr b/benchmarks/blogbench/pkg-descr
new file mode 100644
index 000000000000..57ba50eac34d
--- /dev/null
+++ b/benchmarks/blogbench/pkg-descr
@@ -0,0 +1,8 @@
+Blogbench is a portable filesystem benchmark that tries to reproduce the
+load of a real-world busy file server.
+
+It stresses the filesystem with multiple threads performing random reads,
+writes and rewrites in order to get a realistic idea of the scalability
+and the concurrency a system can handle.
+
+WWW: http://blogbench.pureftpd.org/