aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/bonnie
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-09 05:15:28 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-09 05:15:28 +0800
commit7a99691102229f72ae77e1c05f82564c423a5b2e (patch)
tree76706a7e64e0d608ac9e82b01293940e6d61e105 /benchmarks/bonnie
parent7cf8780313c1ca595e84d4dc00876a884980cfe4 (diff)
downloadfreebsd-ports-gnome-7a99691102229f72ae77e1c05f82564c423a5b2e.tar.gz
freebsd-ports-gnome-7a99691102229f72ae77e1c05f82564c423a5b2e.tar.zst
freebsd-ports-gnome-7a99691102229f72ae77e1c05f82564c423a5b2e.zip
- Support staging
- Add STATIC option (inspired by commented out CFLAGS+=-static)
Diffstat (limited to 'benchmarks/bonnie')
-rw-r--r--benchmarks/bonnie/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/benchmarks/bonnie/Makefile b/benchmarks/bonnie/Makefile
index 5baa622c7b29..085563d007f1 100644
--- a/benchmarks/bonnie/Makefile
+++ b/benchmarks/bonnie/Makefile
@@ -13,15 +13,18 @@ MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Performance Test of Filesystem I/O
NO_WRKSUBDIR= yes
-#CFLAGS+= -static
MAKE_ARGS+= -e CFLAGS="${CFLAGS}"
ALL_TARGET= bsd
-MAN1= bonnie.1
-PLIST_FILES= bin/bonnie
+PLIST_FILES= bin/bonnie man/man1/bonnie.1.gz
+
+OPTIONS_DEFINE= STATIC
+
+STATIC_CFLAGS+= -static
+
+.include <bsd.port.options.mk>
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/Bonnie ${PREFIX}/bin/bonnie
- ${INSTALL_MAN} ${FILESDIR}/bonnie.1 ${PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/Bonnie ${STAGEDIR}${PREFIX}/bin/bonnie
+ ${INSTALL_MAN} ${FILESDIR}/bonnie.1 ${STAGEDIR}${PREFIX}/man/man1
.include <bsd.port.mk>