aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/bytebench
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-01-29 17:39:59 +0800
committerknu <knu@FreeBSD.org>2002-01-29 17:39:59 +0800
commit476fa54a5c6f73ef5e86683a76da131e57c54e53 (patch)
tree7b692450db0c58c5e0c3dc0af9bc30d903667174 /benchmarks/bytebench
parent4da97adde01886935ba4f608070b88f44e9486da (diff)
downloadfreebsd-ports-gnome-476fa54a5c6f73ef5e86683a76da131e57c54e53.tar.gz
freebsd-ports-gnome-476fa54a5c6f73ef5e86683a76da131e57c54e53.tar.zst
freebsd-ports-gnome-476fa54a5c6f73ef5e86683a76da131e57c54e53.zip
Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;
the ECHO macro is set to "echo" by default, but it is set to "true" if make(1) is invoked with the -s option while ECHO_CMD is always set to the echo command. Use command macros where appropriate.
Diffstat (limited to 'benchmarks/bytebench')
-rw-r--r--benchmarks/bytebench/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/benchmarks/bytebench/Makefile b/benchmarks/bytebench/Makefile
index e21e2682a8f7..b6ea556aa8da 100644
--- a/benchmarks/bytebench/Makefile
+++ b/benchmarks/bytebench/Makefile
@@ -17,12 +17,12 @@ do-install:
-${MKDIR} $(PREFIX)/lib/bytebench
for f in Makefile README Run doc pgms results testdir; \
do ${CP} -R $(WRKSRC)/$$f $(PREFIX)/lib/bytebench; done
- ${ECHO} "#!/bin/sh" > $(PREFIX)/bin/bytebench
- ${ECHO} "TMPDIR=\$${TMPDIR-/var/tmp}" >> $(PREFIX)/bin/bytebench
- ${ECHO} "RESULTDIR=/tmp" >> $(PREFIX)/bin/bytebench
- ${ECHO} "export TMPDIR RESULTDIR" >> $(PREFIX)/bin/bytebench
- ${ECHO} "cd $(PREFIX)/lib/bytebench" >> $(PREFIX)/bin/bytebench
- ${ECHO} "exec ./Run \"\$$@\"" >> $(PREFIX)/bin/bytebench
+ ${ECHO_CMD} "#!/bin/sh" > $(PREFIX)/bin/bytebench
+ ${ECHO_CMD} "TMPDIR=\$${TMPDIR-/var/tmp}" >> $(PREFIX)/bin/bytebench
+ ${ECHO_CMD} "RESULTDIR=/tmp" >> $(PREFIX)/bin/bytebench
+ ${ECHO_CMD} "export TMPDIR RESULTDIR" >> $(PREFIX)/bin/bytebench
+ ${ECHO_CMD} "cd $(PREFIX)/lib/bytebench" >> $(PREFIX)/bin/bytebench
+ ${ECHO_CMD} "exec ./Run \"\$$@\"" >> $(PREFIX)/bin/bytebench
${CHMOD} 755 $(PREFIX)/bin/bytebench
${CHMOD} 644 $(PREFIX)/lib/bytebench/Makefile
${CHMOD} 644 $(PREFIX)/lib/bytebench/README