aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/geekbench
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-04-06 02:25:40 +0800
committerpav <pav@FreeBSD.org>2008-04-06 02:25:40 +0800
commit826b6576dd7b003d8ee1cad43442202297d3c127 (patch)
tree084ea519cc0a42392aa2fa524c716bb50c3b1df5 /benchmarks/geekbench
parent3864e16daa7437745a2a0978c8e321bdc727c2de (diff)
downloadfreebsd-ports-gnome-826b6576dd7b003d8ee1cad43442202297d3c127.tar.gz
freebsd-ports-gnome-826b6576dd7b003d8ee1cad43442202297d3c127.tar.zst
freebsd-ports-gnome-826b6576dd7b003d8ee1cad43442202297d3c127.zip
Geekbench is a cross-platform benchmark suite for Mac OS X, Windows,
Solaris, and Linux. Geekbench is designed to measure the performance an average application can expect from both the processor and the memory subsystem. Geekbench's benchmarks are written in platform-neutral C++, and have no platform-specific optimizations. Geekbench is compiled with what we consider the de-facto standard compiler for each platform, with the compiler switches suggested by the compiler vendor for release code. WWW: http://www.geekpatrol.ca/geekbench/ PR: ports/106533 Submitted by: Gea-Suan Lin <gslin@gslin.org>
Diffstat (limited to 'benchmarks/geekbench')
-rw-r--r--benchmarks/geekbench/Makefile26
-rw-r--r--benchmarks/geekbench/distinfo3
-rw-r--r--benchmarks/geekbench/pkg-descr11
3 files changed, 40 insertions, 0 deletions
diff --git a/benchmarks/geekbench/Makefile b/benchmarks/geekbench/Makefile
new file mode 100644
index 000000000000..8d4eef715b7f
--- /dev/null
+++ b/benchmarks/geekbench/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: geekbench
+# Date created: 2006-12-09
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= geekbench
+PORTVERSION= 2
+CATEGORIES= benchmarks
+MASTER_SITES= http://www.primatelabs.ca/download/
+DISTNAME= Geekbench${PORTVERSION}-Linux
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Cross-platform benchmark suite
+
+NO_BUILD= yes
+ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX= yes
+
+PLIST_FILES= bin/geekbench
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/geekbench ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/benchmarks/geekbench/distinfo b/benchmarks/geekbench/distinfo
new file mode 100644
index 000000000000..c6f54c275a2c
--- /dev/null
+++ b/benchmarks/geekbench/distinfo
@@ -0,0 +1,3 @@
+MD5 (Geekbench2-Linux.tar.gz) = 6535f9f46955d815891d917698306ef3
+SHA256 (Geekbench2-Linux.tar.gz) = 10e2db28c9fe2962a12dd9d4cd2ea13c6b7a6ca7bc863b46fff3c6d441a0c2a3
+SIZE (Geekbench2-Linux.tar.gz) = 2010793
diff --git a/benchmarks/geekbench/pkg-descr b/benchmarks/geekbench/pkg-descr
new file mode 100644
index 000000000000..cf0ed615b824
--- /dev/null
+++ b/benchmarks/geekbench/pkg-descr
@@ -0,0 +1,11 @@
+Geekbench is a cross-platform benchmark suite for Mac OS X, Windows,
+Solaris, and Linux. Geekbench is designed to measure the performance
+an average application can expect from both the processor and the
+memory subsystem.
+
+Geekbench's benchmarks are written in platform-neutral C++, and have
+no platform-specific optimizations. Geekbench is compiled with what we
+consider the de-facto standard compiler for each platform, with the
+compiler switches suggested by the compiler vendor for release code.
+
+WWW: http://www.geekpatrol.ca/geekbench/