aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/himenobench
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-07-15 05:36:44 +0800
committermaho <maho@FreeBSD.org>2007-07-15 05:36:44 +0800
commit5698363f34f3120707f0fe20b5939cd164d99f91 (patch)
tree6a4d864dce02fb8c88322d89a81327f6db2fefae /benchmarks/himenobench
parentb08ed306811ec6249cef0798766c80a9291b7b50 (diff)
downloadfreebsd-ports-gnome-5698363f34f3120707f0fe20b5939cd164d99f91.tar.gz
freebsd-ports-gnome-5698363f34f3120707f0fe20b5939cd164d99f91.tar.zst
freebsd-ports-gnome-5698363f34f3120707f0fe20b5939cd164d99f91.zip
Now we use USE_FORTRAN to use FORTRAN compiler.
Diffstat (limited to 'benchmarks/himenobench')
-rw-r--r--benchmarks/himenobench/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/benchmarks/himenobench/Makefile b/benchmarks/himenobench/Makefile
index 1dadd07c4c6d..f3e548023b45 100644
--- a/benchmarks/himenobench/Makefile
+++ b/benchmarks/himenobench/Makefile
@@ -21,15 +21,11 @@ COMMENT= Himeno bench benchmark, solves Poisson eq. with Jacobi's method
BUILD_DEPENDS= ${LOCALBASE}/intel_cc_80/bin/icc:${PORTSDIR}/lang/icc
.endif
.if defined(WITH_IFC)
-BUILD_DEPENDS= ${LOCALBASE}/intel_fc_80/bin/ifort:${PORTSDIR}/lang/ifc
+USE_FORTRAN= ifort
.endif
EXTRACT_DEPENDS= lha:${PORTSDIR}/archivers/lha
-#use gfortran
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
GCCVER:= ${USE_GCC:S/+//}
@@ -55,7 +51,7 @@ PLIST_SUB+= WITH_IFC=""
PLIST_SUB+= WITH_IFC="@comment "
.endif
-.if ${GCCVER} < 4.2
+.if ${USE_FORTRAN} == yes
PLIST_SUB+= WITH_GFORTRAN="@comment "
.else
PLIST_SUB+= WITH_GFORTRAN=""
@@ -67,7 +63,7 @@ do-extract:
cd ${WRKSRC} ; lha xf ${DISTDIR}/${DIST_SUBDIR}/$$i; \
done
do-build:
-.if ${GCCVER} >= 4.2
+.if ${USE_FORTRAN} == yes
cd ${WRKSRC} ; ${FC} ${FFLAGS} -o himenobmtxp himenobmtxp.f90
.endif
# cd ${WRKSRC} ; ${FC} ${FFLAGS} -o himenobmtxp_xl himenobmtxp_xl.f #Too large
@@ -97,7 +93,7 @@ do-build:
.endif
do-install:
# ${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxp_xl ${PREFIX}/bin #Too large
-.if ${GCCVER} >= 4.2
+.if ${USE_FORTRAN} == yes
@${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxp ${PREFIX}/bin
.endif
@${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxp_l ${PREFIX}/bin