aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/himenobench
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-06-21 00:23:28 +0800
committermat <mat@FreeBSD.org>2016-06-21 00:23:28 +0800
commitbc12b6beb26907f267f34c1f8598d120cabecbae (patch)
treee83ee6693050a76e305a95a376451aa583df151e /benchmarks/himenobench
parent5616a93eb39854a280bacec86824bbec7824d5b3 (diff)
downloadfreebsd-ports-gnome-bc12b6beb26907f267f34c1f8598d120cabecbae.tar.gz
freebsd-ports-gnome-bc12b6beb26907f267f34c1f8598d120cabecbae.tar.zst
freebsd-ports-gnome-bc12b6beb26907f267f34c1f8598d120cabecbae.zip
With the power of USES=dos2unix, get rid of most patches and files
with CRLF. While there, run make makepatch, rename patches to use the new scheme, and various fixes. With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'benchmarks/himenobench')
-rw-r--r--benchmarks/himenobench/Makefile3
-rw-r--r--benchmarks/himenobench/files/patch-himenobmtxp__l.f18
-rw-r--r--benchmarks/himenobench/files/patch-himenobmtxp__m.f18
-rw-r--r--benchmarks/himenobench/files/patch-himenobmtxp__s.f18
-rw-r--r--benchmarks/himenobench/files/patch-himenobmtxp__xl.f18
-rw-r--r--benchmarks/himenobench/files/patch-himenobmtxps.c32
6 files changed, 54 insertions, 53 deletions
diff --git a/benchmarks/himenobench/Makefile b/benchmarks/himenobench/Makefile
index fbe39defe14f..a639be3fe742 100644
--- a/benchmarks/himenobench/Makefile
+++ b/benchmarks/himenobench/Makefile
@@ -19,7 +19,8 @@ LICENSE= LGPL20 # (or later)
EXTRACT_DEPENDS= lha:archivers/lha
-USES= fortran zip
+USES= dos2unix fortran zip
+DOS2UNIX_GLOB= *.c *.f
NO_WRKSUBDIR= yes
diff --git a/benchmarks/himenobench/files/patch-himenobmtxp__l.f b/benchmarks/himenobench/files/patch-himenobmtxp__l.f
index 6605b98cc49b..855e8bff2f52 100644
--- a/benchmarks/himenobench/files/patch-himenobmtxp__l.f
+++ b/benchmarks/himenobench/files/patch-himenobmtxp__l.f
@@ -1,10 +1,10 @@
---- himenobmtxp_l.f.orig 2002-01-07 04:54:46 UTC
+--- himenobmtxp_l.f.orig 2016-06-20 13:01:22 UTC
+++ himenobmtxp_l.f
-@@ -39,7 +39,6 @@ C -------------------
- C "use portlib" statement on the next line is for Visual fortran
- C to use UNIX libraries. Please remove it if your system is UNIX.
- C -------------------
-- use portlib
- IMPLICIT REAL*4(a-h,o-z)
- C
- PARAMETER (mimax=513,mjmax=257,mkmax=257)
+@@ -39,7 +39,6 @@ C -------------------
+ C "use portlib" statement on the next line is for Visual fortran
+ C to use UNIX libraries. Please remove it if your system is UNIX.
+ C -------------------
+- use portlib
+ IMPLICIT REAL*4(a-h,o-z)
+ C
+ PARAMETER (mimax=513,mjmax=257,mkmax=257)
diff --git a/benchmarks/himenobench/files/patch-himenobmtxp__m.f b/benchmarks/himenobench/files/patch-himenobmtxp__m.f
index 7aaf759c4d14..97ddd3f1a023 100644
--- a/benchmarks/himenobench/files/patch-himenobmtxp__m.f
+++ b/benchmarks/himenobench/files/patch-himenobmtxp__m.f
@@ -1,10 +1,10 @@
---- himenobmtxp_m.f.orig 2002-01-07 04:54:48 UTC
+--- himenobmtxp_m.f.orig 2016-06-20 13:01:22 UTC
+++ himenobmtxp_m.f
-@@ -39,7 +39,6 @@ C -------------------
- C "use portlib" statement on the next line is for Visual fortran
- C to use UNIX libraries. Please remove it if your system is UNIX.
- C -------------------
-- use portlib
- IMPLICIT REAL*4(a-h,o-z)
- C
- C PARAMETER (mimax=513,mjmax=257,mkmax=257)
+@@ -39,7 +39,6 @@ C -------------------
+ C "use portlib" statement on the next line is for Visual fortran
+ C to use UNIX libraries. Please remove it if your system is UNIX.
+ C -------------------
+- use portlib
+ IMPLICIT REAL*4(a-h,o-z)
+ C
+ C PARAMETER (mimax=513,mjmax=257,mkmax=257)
diff --git a/benchmarks/himenobench/files/patch-himenobmtxp__s.f b/benchmarks/himenobench/files/patch-himenobmtxp__s.f
index 60ffa1510c0b..cea8df8726fa 100644
--- a/benchmarks/himenobench/files/patch-himenobmtxp__s.f
+++ b/benchmarks/himenobench/files/patch-himenobmtxp__s.f
@@ -1,10 +1,10 @@
---- himenobmtxp_s.f.orig 2001-12-17 07:45:16 UTC
+--- himenobmtxp_s.f.orig 2016-06-20 13:01:22 UTC
+++ himenobmtxp_s.f
-@@ -39,7 +39,6 @@ C -------------------
- C "use portlib" statement on the next line is for Visual fortran
- C to use UNIX libraries. Please remove it if your system is UNIX.
- C -------------------
-- use portlib
- IMPLICIT REAL*4(a-h,o-z)
- C
- C PARAMETER (mimax=513,mjmax=257,mkmax=257)
+@@ -39,7 +39,6 @@ C -------------------
+ C "use portlib" statement on the next line is for Visual fortran
+ C to use UNIX libraries. Please remove it if your system is UNIX.
+ C -------------------
+- use portlib
+ IMPLICIT REAL*4(a-h,o-z)
+ C
+ C PARAMETER (mimax=513,mjmax=257,mkmax=257)
diff --git a/benchmarks/himenobench/files/patch-himenobmtxp__xl.f b/benchmarks/himenobench/files/patch-himenobmtxp__xl.f
index 3125952c1d5e..f71a582d45ec 100644
--- a/benchmarks/himenobench/files/patch-himenobmtxp__xl.f
+++ b/benchmarks/himenobench/files/patch-himenobmtxp__xl.f
@@ -1,10 +1,10 @@
---- himenobmtxp_xl.f.orig 2002-01-07 04:54:42 UTC
+--- himenobmtxp_xl.f.orig 2016-06-20 13:01:22 UTC
+++ himenobmtxp_xl.f
-@@ -39,7 +39,6 @@ C -------------------
- C "use portlib" statement on the next line is for Visual fortran
- C to use UNIX libraries. Please remove it if your system is UNIX.
- C -------------------
-- use portlib
- IMPLICIT REAL*4(a-h,o-z)
- C
- PARAMETER (mimax=1025,mjmax=513,mkmax=513)
+@@ -39,7 +39,6 @@ C -------------------
+ C "use portlib" statement on the next line is for Visual fortran
+ C to use UNIX libraries. Please remove it if your system is UNIX.
+ C -------------------
+- use portlib
+ IMPLICIT REAL*4(a-h,o-z)
+ C
+ PARAMETER (mimax=1025,mjmax=513,mkmax=513)
diff --git a/benchmarks/himenobench/files/patch-himenobmtxps.c b/benchmarks/himenobench/files/patch-himenobmtxps.c
index 175cf050112d..b00ab89328ae 100644
--- a/benchmarks/himenobench/files/patch-himenobmtxps.c
+++ b/benchmarks/himenobench/files/patch-himenobmtxps.c
@@ -1,18 +1,18 @@
---- himenobmtxps.c.orig 2002-02-21 00:27:48 UTC
+--- himenobmtxps.c.orig 2016-06-20 13:01:22 UTC
+++ himenobmtxps.c
@@ -37,6 +37,7 @@
- ********************************************************************/
-
- #include <stdio.h>
-+#include <sys/time.h>
-
- #ifdef SSMALL
- #define MIMAX 33
-@@ -245,7 +246,6 @@ mflops(int nn,double cpu,double flop)
- double
- second()
- {
--#include <sys/time.h>
-
- struct timeval tm;
- double t ;
+ ********************************************************************/
+
+ #include <stdio.h>
++#include <sys/time.h>
+
+ #ifdef SSMALL
+ #define MIMAX 33
+@@ -245,7 +246,6 @@ mflops(int nn,double cpu,double flop)
+ double
+ second()
+ {
+-#include <sys/time.h>
+
+ struct timeval tm;
+ double t ;