aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/himenobench
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-02-17 01:15:31 +0800
committertijl <tijl@FreeBSD.org>2014-02-17 01:15:31 +0800
commitf86cbfadd2dbfab1dc1ea72e5084a23c10b1dc6c (patch)
tree49e521faa408bc4bd163bfb0febf91e262772c1c /benchmarks/himenobench
parente04e533cf1bc01e44ad69d14d5c6c205e25bfe3a (diff)
downloadfreebsd-ports-gnome-f86cbfadd2dbfab1dc1ea72e5084a23c10b1dc6c.tar.gz
freebsd-ports-gnome-f86cbfadd2dbfab1dc1ea72e5084a23c10b1dc6c.tar.zst
freebsd-ports-gnome-f86cbfadd2dbfab1dc1ea72e5084a23c10b1dc6c.zip
Convert all USE_FORTRAN=yes to "USES=fortran, USE_GCC=yes". In most cases
USE_GCC=yes has been omitted though. Remove USE_FORTRAN handling from bsd.port.mk and bsd.gcc.mk. Minor cleanups in some ports like USE_GMAKE, NOPORTDOCS,... Exp-run: bdrewery Approved by: portmgr (bdrewery)
Diffstat (limited to 'benchmarks/himenobench')
-rw-r--r--benchmarks/himenobench/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/benchmarks/himenobench/Makefile b/benchmarks/himenobench/Makefile
index b610c1782ced..8d02156243db 100644
--- a/benchmarks/himenobench/Makefile
+++ b/benchmarks/himenobench/Makefile
@@ -22,9 +22,10 @@ USE_LHA= yes
BUILD_DEPENDS= ${LOCALBASE}/intel_cc_80/bin/icc:${PORTSDIR}/lang/icc
.endif
-USE_FORTRAN= yes
.if defined(WITH_IFC)
-USE_FORTRAN= ifort
+USES+= fortran:ifort
+.else
+USES+= fortran
.endif
NO_STAGE= yes
@@ -42,7 +43,7 @@ PLIST_SUB+= WITH_ICC=""
.else
PLIST_SUB+= WITH_ICC="@comment "
.endif
-.if ${USE_FORTRAN} == ifort
+.if defined(WITH_IFC)
FFLAGS_IFC+= -O3 -tpp7 -axN -Vaxlib -ipo
IFC= ${LOCALBASE}/intel_fc_80/bin/ifort
PLIST_SUB+= WITH_IFC=""
@@ -50,14 +51,14 @@ PLIST_SUB+= WITH_IFC=""
PLIST_SUB+= WITH_IFC="@comment "
.endif
-.if ${USE_FORTRAN} != yes
+.if defined(WITH_IFC)
PLIST_SUB+= WITH_GFORTRAN="@comment "
.else
PLIST_SUB+= WITH_GFORTRAN=""
.endif
do-build:
-.if ${USE_FORTRAN} == yes
+.if ! defined(WITH_IFC)
cd ${WRKSRC} ; ${FC} ${FFLAGS} -o himenobmtxp himenobmtxp.f90
.endif
# cd ${WRKSRC} ; ${FC} ${FFLAGS} -o himenobmtxp_xl himenobmtxp_xl.f #Too large
@@ -87,7 +88,7 @@ do-build:
.endif
do-install:
# ${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxp_xl ${PREFIX}/bin #Too large
-.if ${USE_FORTRAN} == yes
+.if ! defined(WITH_IFC)
@${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxp ${PREFIX}/bin
.endif
@${INSTALL_PROGRAM} ${WRKSRC}/himenobmtxp_l ${PREFIX}/bin