aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/hpl
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-09-10 14:28:22 +0800
committerdanfe <danfe@FreeBSD.org>2013-09-10 14:28:22 +0800
commit78066ba4bf1f24287a63a523fbc233275fa5b614 (patch)
tree7894f359bb64b773f08068158212cafe0fbf5a14 /benchmarks/hpl
parent6b4809f40508bd1151b639e53a15140e89e07cfa (diff)
downloadfreebsd-ports-gnome-78066ba4bf1f24287a63a523fbc233275fa5b614.tar.gz
freebsd-ports-gnome-78066ba4bf1f24287a63a523fbc233275fa5b614.tar.zst
freebsd-ports-gnome-78066ba4bf1f24287a63a523fbc233275fa5b614.zip
- Try to fix parallel builds (-jX) by sanitizing targets dependencies
- Stop abusing ALL_TARGET for passing arguments to make(1), use it to specify the actual build target (default target would also be fine, but because of its phony dependencies, some commands would be called twice, which is not good and just asks for trouble) - Modernize LIB_DEPENDS syntax, add missing OPTIONS_DEFINE for DOCS, kill few stray empty lines and commented PORTREVISION while here Approved by: miwi, bapt (portmgr, implicit)
Diffstat (limited to 'benchmarks/hpl')
-rw-r--r--benchmarks/hpl/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/benchmarks/hpl/Makefile b/benchmarks/hpl/Makefile
index 838e4cd4242d..5061c1e49b8c 100644
--- a/benchmarks/hpl/Makefile
+++ b/benchmarks/hpl/Makefile
@@ -3,22 +3,22 @@
PORTNAME= hpl
PORTVERSION= 2.1
-#PORTREVISION= 8
CATEGORIES= benchmarks
MASTER_SITES= ${MASTER_SITE_NETLIB}
-MASTER_SITE_SUBDIR=benchmark/hpl
+MASTER_SITE_SUBDIR= benchmark/hpl
MAINTAINER= oliver@FreeBSD.org
COMMENT= High Performance Computing Linpack Benchmark
-LIB_DEPENDS= blas:${PORTSDIR}/math/blas \
- mpich:${PORTSDIR}/net/mpich2
+LIB_DEPENDS= libblas.so:${PORTSDIR}/math/blas \
+ libmpich.so:${PORTSDIR}/net/mpich2
-MAKE_JOBS_UNSAFE= yes
USE_FORTRAN= yes
USE_LDCONFIG= yes
HPL_ARCH?= FreeBSD_PIV_CBLAS
-ALL_TARGET= arch=${HPL_ARCH}
+MAKE_ARGS= arch=${HPL_ARCH}
+ALL_TARGET= build
+
MAN3= HPL_abort.3 HPL_all_reduce.3 HPL_barrier.3 HPL_bcast.3 \
HPL_binit.3 HPL_broadcast.3 HPL_bwait.3 HPL_copyL.3 \
HPL_daxpy.3 HPL_dcopy.3 HPL_dgemm.3 HPL_dgemv.3 HPL_dger.3 \
@@ -51,6 +51,8 @@ MAN3= HPL_abort.3 HPL_all_reduce.3 HPL_barrier.3 HPL_bcast.3 \
HPL_sum.3 HPL_timer.3 HPL_timer_cputime.3 HPL_timer_walltime.3 \
HPL_warn.3 HPL_xjumpm.3
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
@@ -66,11 +68,10 @@ post-patch:
s|^LAlib[ ]*=.*$$|LAlib = $$\(LAdir\)/lib/libblas.a| ; \
s|libpmpich.a|libmpl.a ${PTHREAD_LIBS}|' \
${WRKSRC}/setup/Make.${HPL_ARCH}
-
@${REINPLACE_CMD} -e 's|HPL\.dat|${PREFIX}/etc/${PORTNAME}/&|' \
${WRKSRC}/testing/ptest/HPL_pdinfo.c
-
@${CP} ${WRKSRC}/setup/Make.${HPL_ARCH} ${WRKSRC}/
+ @${REINPLACE_CMD} -e '/^build/s|$$| startup|' ${WRKSRC}/Makefile
do-install:
${MKDIR} ${PREFIX}/etc/${PORTNAME}