aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/iozone
diff options
context:
space:
mode:
authorjadawin <jadawin@FreeBSD.org>2009-02-17 18:08:13 +0800
committerjadawin <jadawin@FreeBSD.org>2009-02-17 18:08:13 +0800
commit426609fbf9fe41efe9b7c5b567944dedbd4ba288 (patch)
tree0a394019211fff6eba643a8fd449114b87167240 /benchmarks/iozone
parentdcc98e6993cab5d99f1376b5d25441eab3a15c0c (diff)
downloadfreebsd-ports-gnome-426609fbf9fe41efe9b7c5b567944dedbd4ba288.tar.gz
freebsd-ports-gnome-426609fbf9fe41efe9b7c5b567944dedbd4ba288.tar.zst
freebsd-ports-gnome-426609fbf9fe41efe9b7c5b567944dedbd4ba288.zip
- Update to 3.319
PR: ports/131772 Submitted by: Chifeng Qu <chifeng at gmail.com>
Diffstat (limited to 'benchmarks/iozone')
-rw-r--r--benchmarks/iozone/Makefile10
-rw-r--r--benchmarks/iozone/distinfo6
-rw-r--r--benchmarks/iozone/files/patch-makefile11
3 files changed, 9 insertions, 18 deletions
diff --git a/benchmarks/iozone/Makefile b/benchmarks/iozone/Makefile
index 9dfddec26af3..a0eafdc1e873 100644
--- a/benchmarks/iozone/Makefile
+++ b/benchmarks/iozone/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= iozone
-PORTVERSION= 3.283
-PORTREVISION= 1
+PORTVERSION= 3.319
CATEGORIES= benchmarks
MASTER_SITES= http://www.iozone.org/src/current/
DISTNAME= ${PORTNAME}${PORTVERSION:S/./_/}
@@ -40,10 +39,13 @@ CFLAGS+=-DNO_THREADS
.endif
.if defined (WITH_SSH)
-post-patch:
- ${REINPLACE_CMD} -e 's|shell\,\"rsh\"|shell\,\"ssh\"|' ${WRKSRC}/iozone.c
+post-patch::
+ @${REINPLACE_CMD} -e 's|shell\,\"rsh\"|shell\,\"ssh\"|' ${WRKSRC}/iozone.c
.endif
+post-patch::
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/makefile
+
do-install:
${STRIP_CMD} ${WRKSRC}/iozone
${INSTALL_PROGRAM} ${WRKSRC}/iozone ${PREFIX}/bin
diff --git a/benchmarks/iozone/distinfo b/benchmarks/iozone/distinfo
index 8f45f9bee662..8be74062601d 100644
--- a/benchmarks/iozone/distinfo
+++ b/benchmarks/iozone/distinfo
@@ -1,3 +1,3 @@
-MD5 (iozone3_283.tar) = b14081c6b6430d7bcace3fbd93f89519
-SHA256 (iozone3_283.tar) = 88202956d8a78c7cde38a41c6ad6fd70f4637f14e34c4cf04a5f5a43dc001ae2
-SIZE (iozone3_283.tar) = 1525760
+MD5 (iozone3_319.tar) = 16ded14f530b15bc698936452a1ebbd7
+SHA256 (iozone3_319.tar) = 77db62f556467ad676b26b521d549acf2755b2b88a26e270a59f59582fbab220
+SIZE (iozone3_319.tar) = 1576960
diff --git a/benchmarks/iozone/files/patch-makefile b/benchmarks/iozone/files/patch-makefile
deleted file mode 100644
index 8fd45dcbccc4..000000000000
--- a/benchmarks/iozone/files/patch-makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- makefile.orig Sat Oct 28 22:48:00 2006
-+++ makefile Thu Jan 11 21:41:17 2007
-@@ -389,7 +389,7 @@
- #
-
- freebsd: iozone_freebsd.o libbif.o fileop_freebsd.o libasync.o
-- $(CC) $(LDFLAGS) iozone_freebsd.o libbif.o -lpthread libasync.o \
-+ $(CC) $(LDFLAGS) iozone_freebsd.o libbif.o $(PTHREAD_LIBS) libasync.o \
- -o iozone
- $(CC) -O fileop_freebsd.o -o fileop
-