aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/iperf
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-08-18 23:57:22 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-08-18 23:57:22 +0800
commit8d48893b5f058ec8b123e54cd00e166657ed0038 (patch)
tree2fe10fdb20172c064d1ab598ddfabe3a805376cc /benchmarks/iperf
parent16dbb10128a7fcc4b74019d4bd4e90994ca42a43 (diff)
downloadfreebsd-ports-gnome-8d48893b5f058ec8b123e54cd00e166657ed0038.tar.gz
freebsd-ports-gnome-8d48893b5f058ec8b123e54cd00e166657ed0038.tar.zst
freebsd-ports-gnome-8d48893b5f058ec8b123e54cd00e166657ed0038.zip
Add upstream patch to fix 32 bit constant
- Bump PORTREVISION for package change Obtained from: https://sourceforge.net/p/iperf2/code/ci/33812baeb46fce55e45b5ebc7da9dbdd8112a386/ Notified by: Robert McMahon <rjmcmahon@rjmcmahon.com> MFH: 2017Q3
Diffstat (limited to 'benchmarks/iperf')
-rw-r--r--benchmarks/iperf/Makefile1
-rw-r--r--benchmarks/iperf/files/patch-src-Client.cpp11
2 files changed, 12 insertions, 0 deletions
diff --git a/benchmarks/iperf/Makefile b/benchmarks/iperf/Makefile
index 2797a0458fdc..2b7f8c62036a 100644
--- a/benchmarks/iperf/Makefile
+++ b/benchmarks/iperf/Makefile
@@ -3,6 +3,7 @@
PORTNAME= iperf
PORTVERSION= 2.0.10
+PORTREVISION= 1
CATEGORIES= benchmarks
MASTER_SITES= SF/${PORTNAME}2
diff --git a/benchmarks/iperf/files/patch-src-Client.cpp b/benchmarks/iperf/files/patch-src-Client.cpp
new file mode 100644
index 000000000000..9e4e2c8355f1
--- /dev/null
+++ b/benchmarks/iperf/files/patch-src-Client.cpp
@@ -0,0 +1,11 @@
+--- src/Client.cpp.orig 2017-08-09 03:54:14 UTC
++++ src/Client.cpp
+@@ -680,7 +680,7 @@ void Client::Run( void ) {
+
+ // store datagram ID into buffer
+ if (isSeqNo64b(mSettings)) {
+- mBuf_UDP->id = htonl((reportstruct->packetID & 0xFFFFFFFFFL));
++ mBuf_UDP->id = htonl((reportstruct->packetID & 0xFFFFFFFFL));
+ mBuf_UDP->id2 = htonl((((reportstruct->packetID & 0xFFFFFFFF00000000LL) >> 32) | 0x80000000L));
+ } else {
+ mBuf_UDP->id = htonl(((reportstruct->packetID & 0xFFFFFFFFL) | 0x80000000L));