aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/netpipe/Makefile
diff options
context:
space:
mode:
authorjkoshy <jkoshy@FreeBSD.org>1999-02-21 08:02:50 +0800
committerjkoshy <jkoshy@FreeBSD.org>1999-02-21 08:02:50 +0800
commit273a8c0963da2b66301d7b68bce16d8e9610d044 (patch)
treedadf3776c1fc17f8d2906d6c59a20b767a9cbd2a /benchmarks/netpipe/Makefile
parent0eec57e110c4abe280c7769ffaea398afc2259fd (diff)
downloadfreebsd-ports-gnome-273a8c0963da2b66301d7b68bce16d8e9610d044.tar.gz
freebsd-ports-gnome-273a8c0963da2b66301d7b68bce16d8e9610d044.tar.zst
freebsd-ports-gnome-273a8c0963da2b66301d7b68bce16d8e9610d044.zip
Import of NETPIPE, a self scaling network benchmark from AMES lab.
Diffstat (limited to 'benchmarks/netpipe/Makefile')
-rw-r--r--benchmarks/netpipe/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/benchmarks/netpipe/Makefile b/benchmarks/netpipe/Makefile
new file mode 100644
index 000000000000..bc3bf73c9538
--- /dev/null
+++ b/benchmarks/netpipe/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: netpipe
+# Version required: 2.3
+# Date created: 20 Feb 1998
+# Whom: jkoshy
+#
+# $Id$
+
+DISTNAME= netpipe-2.3
+CATEGORIES= benchmarks net
+MASTER_SITES= ftp://ftp.ameslab.gov/pub/netpipe/ \
+ http://www.freebsd.org/~jkoshy/PORTS/
+
+MAINTAINER= jkoshy@freebsd.org
+
+# The default port builds and installs only the TCP version of
+# netpipe(1). The sources also support PVM and MPI.
+
+ALL_TARGET= NPtcp
+MAN1= netpipe.1
+MANCOMPRESSED= no
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/NPtcp ${PREFIX}/bin/NPtcp
+ ${INSTALL_DATA} ${WRKSRC}/netpipe.1 ${PREFIX}/man/man1/netpipe.1
+
+.include <bsd.port.mk>