aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/pathchirp/Makefile
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2005-10-05 21:45:57 +0800
committerehaupt <ehaupt@FreeBSD.org>2005-10-05 21:45:57 +0800
commit2c2b2afd174a41b605901e1a139bc4f3dff49bcf (patch)
treef7fd26fc0a7ea7749e690e923d1a91eeb1b9f750 /benchmarks/pathchirp/Makefile
parent27525273ef7c69ce27fe09c5b0bc655eb6039288 (diff)
downloadfreebsd-ports-gnome-2c2b2afd174a41b605901e1a139bc4f3dff49bcf.tar.gz
freebsd-ports-gnome-2c2b2afd174a41b605901e1a139bc4f3dff49bcf.tar.zst
freebsd-ports-gnome-2c2b2afd174a41b605901e1a139bc4f3dff49bcf.zip
Update benchmarks/pathchirp to version 2.4.1
Modifications: - respect NOPORTDOCS - respect user defined optimization flags PR: 86922 Submitted by: dikshie <dikshie@lapi.itb.ac.id> (maintainer) Approved by: novel (mentor)
Diffstat (limited to 'benchmarks/pathchirp/Makefile')
-rw-r--r--benchmarks/pathchirp/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/benchmarks/pathchirp/Makefile b/benchmarks/pathchirp/Makefile
index c5bfd1e0d952..40568ac0e48b 100644
--- a/benchmarks/pathchirp/Makefile
+++ b/benchmarks/pathchirp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pathchirp
-PORTVERSION= 2.4.0
+PORTVERSION= 2.4.1
CATEGORIES= benchmarks
MASTER_SITES= http://www.spin.rice.edu/Software/pathChirp/
@@ -15,12 +15,22 @@ COMMENT= A measurement tool for available bandwidth estimation
GNU_CONFIGURE= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
PLIST_FILES= bin/pathchirp_rcv bin/pathchirp_snd bin/pathchirp_run
+PORTDOCS= README
+
+post-patch:
+ @${REINPLACE_CMD} -e '/CFLAGS.*O4/d' ${WRKSRC}/configure
do-install:
-.for f in pathchirp_rcv pathchirp_snd pathchirp_run
- ${INSTALL_PROGRAM} ${WRKSRC}/Bin/${ARCH}/${f} ${PREFIX}/bin
+.for f in rcv snd run
+ ${INSTALL_PROGRAM} ${WRKSRC}/Bin/${ARCH}/${PORTNAME}_${f} ${PREFIX}/bin
.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>