aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/pipebench
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-01-18 11:17:18 +0800
committeredwin <edwin@FreeBSD.org>2003-01-18 11:17:18 +0800
commita8613e62c573aa5f0a5a30645911bd18da9021b6 (patch)
tree4b0d26cc34cad00f0862aa99db9d9c9e47b1d85c /benchmarks/pipebench
parent1df83bee896c897f1c7afce2ec2f7259a92da722 (diff)
downloadfreebsd-ports-gnome-a8613e62c573aa5f0a5a30645911bd18da9021b6.tar.gz
freebsd-ports-gnome-a8613e62c573aa5f0a5a30645911bd18da9021b6.tar.zst
freebsd-ports-gnome-a8613e62c573aa5f0a5a30645911bd18da9021b6.zip
misc/pipebench -> benchmarks/pipebench
Diffstat (limited to 'benchmarks/pipebench')
-rw-r--r--benchmarks/pipebench/Makefile27
-rw-r--r--benchmarks/pipebench/distinfo1
-rw-r--r--benchmarks/pipebench/pkg-comment1
-rw-r--r--benchmarks/pipebench/pkg-descr8
-rw-r--r--benchmarks/pipebench/pkg-plist1
5 files changed, 38 insertions, 0 deletions
diff --git a/benchmarks/pipebench/Makefile b/benchmarks/pipebench/Makefile
new file mode 100644
index 000000000000..2e14cda1539b
--- /dev/null
+++ b/benchmarks/pipebench/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# New ports collection makefile for: pipebench
+# Date created: Jan 14, 2003
+# Whom: mich@freebsdcluster.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= pipebench
+PORTVERSION= 0.20
+CATEGORIES= benchmarks
+MASTER_SITES= ftp://ftp.habets.pp.se/pub/synscan/
+
+MAINTAINER= mich@freebsdcluster.org
+
+USE_REINPLACE= yes
+
+post-patch:
+post-patch:
+ @${REINPLACE_CMD} -e "s|^CC|#CC|g" \
+ -e "s|^CFLAGS|#CFLAGS|g" ${WRKSRC}/Makefile
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pipebench ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/pipebench.1 ${PREFIX}/man/man1
+
+MAN1= pipebench.1
+.include <bsd.port.mk>
diff --git a/benchmarks/pipebench/distinfo b/benchmarks/pipebench/distinfo
new file mode 100644
index 000000000000..d2ecfcf85b62
--- /dev/null
+++ b/benchmarks/pipebench/distinfo
@@ -0,0 +1 @@
+MD5 (pipebench-0.20.tar.gz) = 87093497c36ab29190777bf2c7f381a3
diff --git a/benchmarks/pipebench/pkg-comment b/benchmarks/pipebench/pkg-comment
new file mode 100644
index 000000000000..ed3fb8697ccb
--- /dev/null
+++ b/benchmarks/pipebench/pkg-comment
@@ -0,0 +1 @@
+Pipebench shows current throughput/amount of data through a pipe
diff --git a/benchmarks/pipebench/pkg-descr b/benchmarks/pipebench/pkg-descr
new file mode 100644
index 000000000000..6b1453945bbe
--- /dev/null
+++ b/benchmarks/pipebench/pkg-descr
@@ -0,0 +1,8 @@
+Pipebench shows the current throughput and amount of data going through a
+pipe. It can be used to show the progress of a large md5sum process:
+cat bigfile | pipebench | md5sum.
+
+WWW: http://www.habets.pp.se/synscan/programs.php?prog=pipebench
+
+ - Michael L. Hostbaek
+ mich@freebsdcluster.org
diff --git a/benchmarks/pipebench/pkg-plist b/benchmarks/pipebench/pkg-plist
new file mode 100644
index 000000000000..5140f6dec434
--- /dev/null
+++ b/benchmarks/pipebench/pkg-plist
@@ -0,0 +1 @@
+bin/pipebench