aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/scimark2c
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2010-10-12 04:04:01 +0800
committerthierry <thierry@FreeBSD.org>2010-10-12 04:04:01 +0800
commite5ff953f2a8a373a4555e33b25ad067ac056f1ed (patch)
tree07142e997ace2c0927dbd92f58c118c8be2218e8 /benchmarks/scimark2c
parentde4fc42b8eea61a769daca03d6cc499ef13295a5 (diff)
downloadfreebsd-ports-gnome-e5ff953f2a8a373a4555e33b25ad067ac056f1ed.tar.gz
freebsd-ports-gnome-e5ff953f2a8a373a4555e33b25ad067ac056f1ed.tar.zst
freebsd-ports-gnome-e5ff953f2a8a373a4555e33b25ad067ac056f1ed.zip
Upgrade to 2.1.
Diffstat (limited to 'benchmarks/scimark2c')
-rw-r--r--benchmarks/scimark2c/Makefile13
-rw-r--r--benchmarks/scimark2c/distinfo6
-rw-r--r--benchmarks/scimark2c/files/patch-Makefile8
3 files changed, 9 insertions, 18 deletions
diff --git a/benchmarks/scimark2c/Makefile b/benchmarks/scimark2c/Makefile
index 8c48e5d0cc67..af3d199ebaf3 100644
--- a/benchmarks/scimark2c/Makefile
+++ b/benchmarks/scimark2c/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= scimark2c
-PORTVERSION= 2.0
+DISTVERSION= 2_1
CATEGORIES= benchmarks
MASTER_SITES= http://math.nist.gov/scimark2/
-DISTNAME= ${PORTNAME}
+DISTNAME= ${PORTNAME:S/2/${DISTVERSION}/}
MAINTAINER= thierry@pompo.net
COMMENT= An ANSI C version of the SciMark2 benchmark
@@ -18,15 +18,8 @@ PLIST_FILES= bin/scimark2
WRKSRC= ${WRKDIR}
USE_ZIP= yes
-MALLOC2STD= kernel.c Stopwatch.c Random.c array.c
-
-post-patch:
-.for file in ${MALLOC2STD}
- @${REINPLACE_CMD} -e "s|malloc.h|stdlib.h|" ${WRKSRC}/${file}
-.endfor
-
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/scimark2 ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/scimark2 ${PREFIX}/bin
post-install:
@${ECHO} "*****************************************************************************"
diff --git a/benchmarks/scimark2c/distinfo b/benchmarks/scimark2c/distinfo
index c3da85a7c3fb..f36374b95f00 100644
--- a/benchmarks/scimark2c/distinfo
+++ b/benchmarks/scimark2c/distinfo
@@ -1,3 +1,3 @@
-MD5 (scimark2c.zip) = 3fe0d6b3c8068bf7481ce45fe51d96d0
-SHA256 (scimark2c.zip) = 53d6bffc6468f20a55bc3184ec293bb73bcb2b01cce4965869845ed2210b81ff
-SIZE (scimark2c.zip) = 14336
+MD5 (scimark2_1c.zip) = 6cc8d6d5312a07e32316c03580e0206b
+SHA256 (scimark2_1c.zip) = 223464cd7e90b4c22e2af08dbae6f6faa33e65b01e1c58e5a176837bc67958be
+SIZE (scimark2_1c.zip) = 13792
diff --git a/benchmarks/scimark2c/files/patch-Makefile b/benchmarks/scimark2c/files/patch-Makefile
index 0255950e5def..7a688dc0f190 100644
--- a/benchmarks/scimark2c/files/patch-Makefile
+++ b/benchmarks/scimark2c/files/patch-Makefile
@@ -1,13 +1,11 @@
---- Makefile.orig Thu Jul 6 00:07:45 2000
-+++ Makefile Sat Apr 5 22:53:49 2003
-@@ -5,8 +5,8 @@
+--- Makefile.orig 2006-07-26 21:30:46.000000000 +0200
++++ Makefile 2010-10-11 21:48:39.000000000 +0200
+@@ -5,7 +5,7 @@
all: scimark2
-CC = cc
--CFLAGS = -O
+#CC = cc
-+#CFLAGS = -O
LDFLAGS =
OBJS = FFT.o kernel.o Stopwatch.o Random.o SOR.o SparseCompRow.o \