aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/stream/Makefile
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2001-11-07 04:17:17 +0800
committerpetef <petef@FreeBSD.org>2001-11-07 04:17:17 +0800
commitaebf93a400f51d4d800fe602c856634b62919390 (patch)
treec1f180742cc053424f531aafa1be7d0e9ff5a3db /benchmarks/stream/Makefile
parent71984d540e90285841b579cf2cf42e1093269198 (diff)
downloadfreebsd-ports-gnome-aebf93a400f51d4d800fe602c856634b62919390.tar.gz
freebsd-ports-gnome-aebf93a400f51d4d800fe602c856634b62919390.tar.zst
freebsd-ports-gnome-aebf93a400f51d4d800fe602c856634b62919390.zip
Add stream-1.0, a synthetic benchmark program that measures sustainable
memory bandwidth PR: 27272 Submitted by: Scott Flatman <sf@dsinw.com>
Diffstat (limited to 'benchmarks/stream/Makefile')
-rw-r--r--benchmarks/stream/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/benchmarks/stream/Makefile b/benchmarks/stream/Makefile
new file mode 100644
index 000000000000..bab83bfac488
--- /dev/null
+++ b/benchmarks/stream/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: stream
+# Date created: 10 May 2001
+# Whom: Scott Flatman <sf@dsinw.com>
+#
+# $FreeBSD$
+
+PORTNAME= stream
+PORTVERSION= 1.0
+CATEGORIES= benchmarks
+MASTER_SITES= ftp://ftp.cs.virginia.edu/pub/stream/Code/
+DISTFILES= second_cpu.c stream_d.c
+DIST_SUBDIR= stream-${PORTVERSION}
+
+MAINTAINER= sf@dsinw.com
+
+MAKEFILE= ${FILESDIR}/Makefile
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @${CP} -r ${_DISTDIR} ${WRKDIR}
+
+post-install:
+ strip ${PREFIX}/bin/stream
+
+.include <bsd.port.mk>