aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/stress-ng
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-10-20 00:22:48 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-10-20 00:22:48 +0800
commite9467d2363ce8995af3893c5de3f1f2bdf2b36df (patch)
tree3c7528c906829b34219f38d28527942d1af915cd /benchmarks/stress-ng
parentbeda9006faea7236dbe4e72c734e1a2dcb0a437d (diff)
downloadfreebsd-ports-gnome-e9467d2363ce8995af3893c5de3f1f2bdf2b36df.tar.gz
freebsd-ports-gnome-e9467d2363ce8995af3893c5de3f1f2bdf2b36df.tar.zst
freebsd-ports-gnome-e9467d2363ce8995af3893c5de3f1f2bdf2b36df.zip
- Update to 0.07.00
PR: 213591 Submitted by: luca.pizzamiglio@gmail.com (maintainer)
Diffstat (limited to 'benchmarks/stress-ng')
-rw-r--r--benchmarks/stress-ng/Makefile2
-rw-r--r--benchmarks/stress-ng/distinfo6
-rw-r--r--benchmarks/stress-ng/files/patch-Makefile11
-rw-r--r--benchmarks/stress-ng/files/patch-stress-cpu.c4
4 files changed, 17 insertions, 6 deletions
diff --git a/benchmarks/stress-ng/Makefile b/benchmarks/stress-ng/Makefile
index 079afc78af17..d7104a595e5d 100644
--- a/benchmarks/stress-ng/Makefile
+++ b/benchmarks/stress-ng/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= stress-ng
-PORTVERSION= 0.06.18
+PORTVERSION= 0.07.00
CATEGORIES= benchmarks
MASTER_SITES= http://kernel.ubuntu.com/~cking/tarballs/stress-ng/
diff --git a/benchmarks/stress-ng/distinfo b/benchmarks/stress-ng/distinfo
index b1884ce60dca..45da44753084 100644
--- a/benchmarks/stress-ng/distinfo
+++ b/benchmarks/stress-ng/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1476199771
-SHA256 (stress-ng-0.06.18.tar.gz) = fa073af9925597a1792c4c21c53e0841da4c008f3cf9522bff127ad005da8eaa
-SIZE (stress-ng-0.06.18.tar.gz) = 339207
+TIMESTAMP = 1476778500
+SHA256 (stress-ng-0.07.00.tar.gz) = d57a2d510b9086f7c6557c05ca5b7b247bf74f03650e284c15a78e5b0cdca319
+SIZE (stress-ng-0.07.00.tar.gz) = 341086
diff --git a/benchmarks/stress-ng/files/patch-Makefile b/benchmarks/stress-ng/files/patch-Makefile
new file mode 100644
index 000000000000..52841f082b89
--- /dev/null
+++ b/benchmarks/stress-ng/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2016-10-17 09:59:22 UTC
++++ Makefile
+@@ -601,7 +601,7 @@ stress-cpu.o: stress-cpu.c
+ @rm -f test-decimal.c test-decimal.o
+
+ perf.o: perf.c perf-event.c
+- @gcc -E perf-event.c | grep "PERF_COUNT" | sed 's/,/ /' | awk {'print "#define _SNG_" $$1 " (1)"'} > perf-event.h
++ @$(CC) -E perf-event.c | grep "PERF_COUNT" | sed 's/,/ /' | awk {'print "#define _SNG_" $$1 " (1)"'} > perf-event.h
+ $(CC) $(CFLAGS) -c -o $@ $<
+
+ stress-wcstr.o: stress-wcstr.c
diff --git a/benchmarks/stress-ng/files/patch-stress-cpu.c b/benchmarks/stress-ng/files/patch-stress-cpu.c
index b8a2a329d1ac..2fabe7590512 100644
--- a/benchmarks/stress-ng/files/patch-stress-cpu.c
+++ b/benchmarks/stress-ng/files/patch-stress-cpu.c
@@ -1,4 +1,4 @@
---- stress-cpu.c.orig 2016-07-15 14:26:33 UTC
+--- stress-cpu.c.orig 2016-10-17 09:59:22 UTC
+++ stress-cpu.c
@@ -57,7 +57,6 @@
#define ccosl ccos
@@ -7,4 +7,4 @@
-#define powl pow
#endif
- /*
+ #if defined(__minix__)