aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/super-smack/Makefile
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2012-11-28 19:09:39 +0800
committerak <ak@FreeBSD.org>2012-11-28 19:09:39 +0800
commit09ca1216ad8edc4da1c0b21a82a36a1d524a9838 (patch)
tree94505710948bbaefc29e545dc02d32b12bba4df5 /benchmarks/super-smack/Makefile
parent654f964cc8f07e29d8aa19a91b4bf2c7811d7033 (diff)
downloadfreebsd-ports-gnome-09ca1216ad8edc4da1c0b21a82a36a1d524a9838.tar.gz
freebsd-ports-gnome-09ca1216ad8edc4da1c0b21a82a36a1d524a9838.tar.zst
freebsd-ports-gnome-09ca1216ad8edc4da1c0b21a82a36a1d524a9838.zip
- Remove indefinite article from COMMENT
- Use standard option name for postgresql - Convert tab to space after WWW: in pkg-descr - Convert Makefile headers to new style [1] - Convert to new options framework [1] PR: ports/173563 (based on) [1] Submitted by: Charlie & <edward@rdtan.net> Approved by: Gea-Suan Lin <gslin@gslin.org> (maintainer) Feature safe: yes
Diffstat (limited to 'benchmarks/super-smack/Makefile')
-rw-r--r--benchmarks/super-smack/Makefile26
1 files changed, 13 insertions, 13 deletions
diff --git a/benchmarks/super-smack/Makefile b/benchmarks/super-smack/Makefile
index bcdbdd70e7ed..589642d6f0e4 100644
--- a/benchmarks/super-smack/Makefile
+++ b/benchmarks/super-smack/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: super-smack
-# Date created: 2005-12-10
-# Whom: Gea-Suan Lin <gslin@ccca.nctu.edu.tw>
-#
+# Created by: Gea-Suan Lin <gslin@ccca.nctu.edu.tw>
# $FreeBSD$
-#
PORTNAME= super-smack
PORTVERSION= 1.3
@@ -12,7 +8,7 @@ CATEGORIES= benchmarks databases
MASTER_SITES= http://vegan.net/tony/supersmack/
MAINTAINER= gslin@gslin.org
-COMMENT= A benchmarking, stress testing, and load generation tool for Databases
+COMMENT= Benchmarking, stress testing, and load generation tool for Databases
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-smacks-dir=${DATADIR}
@@ -20,26 +16,30 @@ MAKE_JOBS_UNSAFE= yes
PORTDOCS= README TUTORIAL
-OPTIONS= MYSQL "Enable MySQL support" on \
- POSTGRESQL "Enable PostgreSQL support" off
+OPTIONS_MULTI= DB
+OPTIONS_MULTI_DB= MYSQL PGSQL
+OPTIONS_DEFAULT= MYSQL
-.include <bsd.port.pre.mk>
+PGSQL_DESC= Enable PostgreSQL support
+MYSQL_DESC= Enable MySQL support
-.if !defined(WITHOUT_MYSQL)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
CONFIGURE_ARGS+=--with-mysql \
--with-mysql-include=${LOCALBASE}/include/mysql \
--with-mysql-lib=${LOCALBASE}/lib/mysql
.endif
-.if defined(WITH_POSTGRESQL)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PGSQL= yes
CONFIGURE_ARGS+=--with-pgsql \
--with-pgsql-include=${LOCALBASE}/include \
--with-pgsql-lib=${LOCALBASE}/lib
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
@@ -47,4 +47,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>