aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/super-smack/Makefile
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2009-06-10 15:59:53 +0800
committeritetcu <itetcu@FreeBSD.org>2009-06-10 15:59:53 +0800
commitd611071291cab011384d451b5ae21be62fc50dc5 (patch)
tree121b56d9696d6e8a6b17e54bfc873412d417cc58 /benchmarks/super-smack/Makefile
parent995f8084d113462d5801dbf162fa851d81fa4e4b (diff)
downloadfreebsd-ports-gnome-d611071291cab011384d451b5ae21be62fc50dc5.tar.gz
freebsd-ports-gnome-d611071291cab011384d451b5ae21be62fc50dc5.tar.zst
freebsd-ports-gnome-d611071291cab011384d451b5ae21be62fc50dc5.zip
Fix build with custom LOCALBASE
Submitted by: Sahil Tandon Reported by: QATty Approved by: portmgr (itetcu@) No cookie for: maintainer
Diffstat (limited to 'benchmarks/super-smack/Makefile')
-rw-r--r--benchmarks/super-smack/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/benchmarks/super-smack/Makefile b/benchmarks/super-smack/Makefile
index 5617f98b6bfe..df4818fd4bb6 100644
--- a/benchmarks/super-smack/Makefile
+++ b/benchmarks/super-smack/Makefile
@@ -26,12 +26,16 @@ OPTIONS= MYSQL "Enable MySQL support" on \
.if !defined(WITHOUT_MYSQL)
USE_MYSQL= yes
-CONFIGURE_ARGS+= --with-mysql
+CONFIGURE_ARGS+=--with-mysql \
+ --with-mysql-include=${LOCALBASE}/include/mysql \
+ --with-mysql-lib=${LOCALBASE}/lib/mysql
.endif
.if defined(WITH_POSTGRESQL)
USE_PGSQL= yes
-CONFIGURE_ARGS+= --with-pgsql
+CONFIGURE_ARGS+=--with-pgsql \
+ --with-pgsql-include=${LOCALBASE}/include
+ --with-pgsql-lib=${LOCALBASE}/lib
.endif
.if !defined(NOPORTDOCS)