aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/super-smack
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-02-18 09:10:17 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-02-18 09:10:17 +0800
commited14904773f28e9a5765b0dbb5d3a6fcd6742d99 (patch)
tree6e015be13f18a6587599471a970a55d9653b7255 /benchmarks/super-smack
parente6bb788fdc0606ce66201525837b843ed82b98b7 (diff)
downloadfreebsd-ports-gnome-ed14904773f28e9a5765b0dbb5d3a6fcd6742d99.tar.gz
freebsd-ports-gnome-ed14904773f28e9a5765b0dbb5d3a6fcd6742d99.tar.zst
freebsd-ports-gnome-ed14904773f28e9a5765b0dbb5d3a6fcd6742d99.zip
- Install README and TUTORIAL as portdocs
PR: 128098 Submitted by: hip0 <hipodilski at gmail dot com> Approved by: maintainer timeout
Diffstat (limited to 'benchmarks/super-smack')
-rw-r--r--benchmarks/super-smack/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/benchmarks/super-smack/Makefile b/benchmarks/super-smack/Makefile
index dc2ef20e6f46..5617f98b6bfe 100644
--- a/benchmarks/super-smack/Makefile
+++ b/benchmarks/super-smack/Makefile
@@ -7,6 +7,7 @@
PORTNAME= super-smack
PORTVERSION= 1.3
+PORTREVISION= 1
CATEGORIES= benchmarks databases
MASTER_SITES= http://vegan.net/tony/supersmack/
@@ -16,6 +17,8 @@ COMMENT= A benchmarking, stress testing, and load generation tool for Databases
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-smacks-dir=${DATADIR}
+PORTDOCS= README TUTORIAL
+
OPTIONS= MYSQL "Enable MySQL support" on \
POSTGRESQL "Enable PostgreSQL support" off
@@ -31,4 +34,12 @@ USE_PGSQL= yes
CONFIGURE_ARGS+= --with-pgsql
.endif
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
.include <bsd.port.post.mk>