aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/webbench
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-01-31 22:56:33 +0800
committerpav <pav@FreeBSD.org>2004-01-31 22:56:33 +0800
commit4f7301f8f083fde496141cf48dbf5cd469534545 (patch)
tree2375728417bdc14ed8fc86a1901a5c6cf4583642 /benchmarks/webbench
parentd77637f3725bf9a1f1d320100e2071e1c9b5c38e (diff)
downloadfreebsd-ports-gnome-4f7301f8f083fde496141cf48dbf5cd469534545.tar.gz
freebsd-ports-gnome-4f7301f8f083fde496141cf48dbf5cd469534545.tar.zst
freebsd-ports-gnome-4f7301f8f083fde496141cf48dbf5cd469534545.zip
- Fix build on -STABLE
PR: ports/62151 Submitted by: Radim Kolar <hsn@netmag.cz> (maintainer)
Diffstat (limited to 'benchmarks/webbench')
-rw-r--r--benchmarks/webbench/Makefile3
-rw-r--r--benchmarks/webbench/distinfo1
-rw-r--r--benchmarks/webbench/files/patch-Makefile13
3 files changed, 17 insertions, 0 deletions
diff --git a/benchmarks/webbench/Makefile b/benchmarks/webbench/Makefile
index 077e9baf64f5..d3efcc13c8e9 100644
--- a/benchmarks/webbench/Makefile
+++ b/benchmarks/webbench/Makefile
@@ -16,6 +16,9 @@ COMMENT= Simple forking web benchmark
USE_GETOPT_LONG=yes
+MAKE_ENV+= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+
.if !defined(NO_INSTALL_MANPAGES)
MAN1= webbench.1
.endif
diff --git a/benchmarks/webbench/distinfo b/benchmarks/webbench/distinfo
index 9bc90366779a..69bcfb64804c 100644
--- a/benchmarks/webbench/distinfo
+++ b/benchmarks/webbench/distinfo
@@ -1 +1,2 @@
MD5 (webbench-1.4.tar.gz) = 912e5359a6917dd618c0a2821f615b89
+SIZE (webbench-1.4.tar.gz) = 7663
diff --git a/benchmarks/webbench/files/patch-Makefile b/benchmarks/webbench/files/patch-Makefile
new file mode 100644
index 000000000000..192ca29e6b00
--- /dev/null
+++ b/benchmarks/webbench/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig Thu Jan 15 12:09:01 2004
++++ Makefile Thu Jan 29 20:38:03 2004
+@@ -20,8 +20,8 @@
+ install -m 644 debian/changelog $(DESTDIR)$(PREFIX)/share/doc/webbench
+ .endif
+
+-webbench: webbench.o Makefile
+- $(CC) $(CFLAGS) $(LDFLAGS) -o webbench webbench.o $(LIBS)
++webbench: Makefile
++ ${CC} $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o webbench webbench.c $(LIBS)
+
+ clean:
+ -rm -f *.o webbench *~ core tags