aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/xengine/Makefile
diff options
context:
space:
mode:
authorandreas <andreas@FreeBSD.org>1997-02-16 21:30:45 +0800
committerandreas <andreas@FreeBSD.org>1997-02-16 21:30:45 +0800
commitd98b5faee734d8e26d5ec2e21de5939d4c42020a (patch)
tree6c48e6c9a45a68e7754f15e5349c446c1fb1f533 /benchmarks/xengine/Makefile
parent600a7ecfb73f865f84a1b74b95f5e448eb96341d (diff)
downloadfreebsd-ports-gnome-d98b5faee734d8e26d5ec2e21de5939d4c42020a.tar.gz
freebsd-ports-gnome-d98b5faee734d8e26d5ec2e21de5939d4c42020a.tar.zst
freebsd-ports-gnome-d98b5faee734d8e26d5ec2e21de5939d4c42020a.zip
new xengine port. Closes PR 2249.
It displays a part of a motor. The faster your X server is, the more rpm you get ;-) Guess how many rpm's I got, when I started with X11 years ago .... 32 rpm with an ET4000 VGA card on a 386 4MB running Interactive Unix ;-))
Diffstat (limited to 'benchmarks/xengine/Makefile')
-rw-r--r--benchmarks/xengine/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/benchmarks/xengine/Makefile b/benchmarks/xengine/Makefile
new file mode 100644
index 000000000000..3bc0162133e6
--- /dev/null
+++ b/benchmarks/xengine/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: xengine
+# Version required: pl1
+# Date created: 17 January 1997
+# Whom: FURUSAWA,Kazuhisa <furusawa@com.cs.osakafu-u.ac.jp>
+
+DISTNAME= xengine-pl1
+PKGNAME= xengine
+CATEGORIES= benchmarks x11
+MASTER_SITES= ftp://ftp.lab.kdd.co.jp/Usenet/comp.sources.x/volume09/xengine/
+DISTFILES= part01.z patch1.z
+
+MAINTAINER= furusawa@com.cs.osakafu-u.ac.jp
+
+BUILD_DEPENDS= gunshar:${PORTSDIR}/archivers/gshar+gunshar
+
+DIST_SUBDIR= xengine
+WRKSRC= $(WRKDIR)
+USE_IMAKE= yes
+
+EXTRACT_CMD= zcat
+EXTRACT_SUFX= .z
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= | gunshar -d $(WRKDIR)
+
+pre-patch:
+ @cd $(WRKSRC) ; patch < xengine.patch1
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @mkdir -p $(PREFIX)/share/doc/xengine
+ @install -c $(WRKSRC)/README $(PREFIX)/share/doc/xengine
+.endif
+
+.include <bsd.port.mk>