aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-11-20 01:23:57 +0800
committerdanfe <danfe@FreeBSD.org>2015-11-20 01:23:57 +0800
commit04350b00dadbc1c866fef63c32e3efdafa58b219 (patch)
tree5d31e9fe76a5694e0271278d5ff15cd6cec21189 /benchmarks
parent1b2eab323c0e57405d83143a6bb03b1e159030b1 (diff)
downloadfreebsd-ports-gnome-04350b00dadbc1c866fef63c32e3efdafa58b219.tar.gz
freebsd-ports-gnome-04350b00dadbc1c866fef63c32e3efdafa58b219.tar.zst
freebsd-ports-gnome-04350b00dadbc1c866fef63c32e3efdafa58b219.zip
- Switch to DISTVERSION to avoid hard-coded value in MASTER_SITES
- Similarly, avoid hardcoding the port name in DISTNAME - Wrap one overly long line when installing programs
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/iorate/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/benchmarks/iorate/Makefile b/benchmarks/iorate/Makefile
index 5ec6de99296a..09c77b55a276 100644
--- a/benchmarks/iorate/Makefile
+++ b/benchmarks/iorate/Makefile
@@ -1,10 +1,10 @@
# $FreeBSD$
PORTNAME= iorate
-PORTVERSION= 3.05
+DISTVERSION= 3-05
CATEGORIES= benchmarks
-MASTER_SITES= http://sites.google.com/site/vwiorate/downloads/3-05/
-DISTNAME= iorate-${PORTVERSION}-src
+MASTER_SITES= http://sites.google.com/site/vwiorate/downloads/${DISTVERSION}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
EXTRACT_SUFX= .tar
MAINTAINER= blttll@gmail.com
@@ -23,7 +23,8 @@ post-patch:
@${REINPLACE_CMD} -e 's,^CFLAGS ,&+,' ${WRKSRC}/${MAKEFILE}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/iorate ${WRKSRC}/ior_rand ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/iorate ${WRKSRC}/ior_rand \
+ ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/*.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_SCRIPT} ${WRKSRC}/cycle ${WRKSRC}/gen_* ${WRKSRC}/run_* \