aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authorolivier <olivier@FreeBSD.org>2016-11-28 20:47:18 +0800
committerolivier <olivier@FreeBSD.org>2016-11-28 20:47:18 +0800
commit10831c9f5824763f86c7100e71fa391cfc808443 (patch)
tree326d51699e14e6931f5db3e1f6ea171639cebd0b /benchmarks
parentce842782e4b76836bd00a8c1bd64b023870c3eda (diff)
downloadfreebsd-ports-gnome-10831c9f5824763f86c7100e71fa391cfc808443.tar.gz
freebsd-ports-gnome-10831c9f5824763f86c7100e71fa391cfc808443.tar.zst
freebsd-ports-gnome-10831c9f5824763f86c7100e71fa391cfc808443.zip
Update to 0.07.07
PR: 214899 Submitted by: luca.pizzamiglio@gmail.com (maintainer) Approved by: jadawin (mentor) Differential Revision: https://reviews.freebsd.org/D8661
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/stress-ng/Makefile4
-rw-r--r--benchmarks/stress-ng/distinfo6
-rw-r--r--benchmarks/stress-ng/files/extrapatch-Makefile6
-rw-r--r--benchmarks/stress-ng/files/extrapatch-stress-cpu.c10
-rw-r--r--benchmarks/stress-ng/files/extrapatch-stress-cpu.h10
5 files changed, 18 insertions, 18 deletions
diff --git a/benchmarks/stress-ng/Makefile b/benchmarks/stress-ng/Makefile
index 42ab050c1aa5..79d36af948c8 100644
--- a/benchmarks/stress-ng/Makefile
+++ b/benchmarks/stress-ng/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= stress-ng
-PORTVERSION= 0.07.02
+PORTVERSION= 0.07.07
CATEGORIES= benchmarks
MASTER_SITES= http://kernel.ubuntu.com/~cking/tarballs/stress-ng/
@@ -21,7 +21,7 @@ PLIST_FILES= bin/stress-ng man/man1/stress-ng.1.gz
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 1000000
-EXTRA_PATCHES+= ${FILESDIR}/extrapatch-stress-cpu.c \
+EXTRA_PATCHES+= ${FILESDIR}/extrapatch-stress-cpu.h \
${FILESDIR}/extrapatch-Makefile
.endif
diff --git a/benchmarks/stress-ng/distinfo b/benchmarks/stress-ng/distinfo
index 4a170183ff5b..780f37b536e7 100644
--- a/benchmarks/stress-ng/distinfo
+++ b/benchmarks/stress-ng/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1478684146
-SHA256 (stress-ng-0.07.02.tar.gz) = 8b9cf270bd0288e23d93d2b41f76c94f9af989f5fede1432f2b1e49f9eda6f7f
-SIZE (stress-ng-0.07.02.tar.gz) = 343763
+TIMESTAMP = 1480323994
+SHA256 (stress-ng-0.07.07.tar.gz) = 263919f026bd7d864b822d799f66ddd2406ea6e78677edc53226fcb184f674e6
+SIZE (stress-ng-0.07.07.tar.gz) = 342120
diff --git a/benchmarks/stress-ng/files/extrapatch-Makefile b/benchmarks/stress-ng/files/extrapatch-Makefile
index 3f85538ce938..35ad37b03268 100644
--- a/benchmarks/stress-ng/files/extrapatch-Makefile
+++ b/benchmarks/stress-ng/files/extrapatch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2016-02-19 13:41:26.000000000 +0100
-+++ Makefile 2016-02-19 16:02:35.583431776 +0100
-@@ -307,7 +307,7 @@
+--- Makefile.orig 2016-11-28 10:42:07.029535000 +0100
++++ Makefile 2016-11-28 10:42:33.403489000 +0100
+@@ -387,7 +387,7 @@
@$(CC) $(CFLAGS) -c -o $@ $<
stress-ng: $(OBJS)
diff --git a/benchmarks/stress-ng/files/extrapatch-stress-cpu.c b/benchmarks/stress-ng/files/extrapatch-stress-cpu.c
deleted file mode 100644
index 689307658449..000000000000
--- a/benchmarks/stress-ng/files/extrapatch-stress-cpu.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- stress-cpu.c.orig 2015-09-18 14:50:12 UTC
-+++ stress-cpu.c
-@@ -23,6 +23,7 @@
- *
- */
- #define _GNU_SOURCE
-+#define _DECLARE_C99_LDBL_MATH 1
-
- #include <stdio.h>
- #include <stdlib.h>
diff --git a/benchmarks/stress-ng/files/extrapatch-stress-cpu.h b/benchmarks/stress-ng/files/extrapatch-stress-cpu.h
new file mode 100644
index 000000000000..211bf4ded7da
--- /dev/null
+++ b/benchmarks/stress-ng/files/extrapatch-stress-cpu.h
@@ -0,0 +1,10 @@
+--- stress-ng.h.orig 2016-11-28 10:45:15.430051000 +0100
++++ stress-ng.h 2016-11-28 10:45:25.621013000 +0100
+@@ -27,6 +27,7 @@
+ #define __STRESS_NG_H__
+
+ #define _GNU_SOURCE
++#define _DECLARE_C99_LDBL_MATH 1
+
+ #include <stdarg.h>
+ #include <stdint.h>